Bug 13134 - ALPS Touchpad not getting recognized anymore
Summary: ALPS Touchpad not getting recognized anymore
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Dmitry Torokhov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-18 01:30 UTC by Pablo López Martín
Modified: 2009-10-20 05:20 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
dmesg with i8042.debug kernel option (95.25 KB, text/plain)
2009-04-18 01:30 UTC, Pablo López Martín
Details
lspci -vv (12.45 KB, text/plain)
2009-04-18 01:30 UTC, Pablo López Martín
Details
Output of cat /proc/bus/input/devices (1.63 KB, text/plain)
2009-04-18 01:31 UTC, Pablo López Martín
Details
Output of lshal (88.58 KB, text/plain)
2009-04-18 01:32 UTC, Pablo López Martín
Details
ALPS Touchpad picture -- Toshiba Satellite Pro M10 (5.78 KB, image/jpeg)
2009-04-19 17:22 UTC, Pablo López Martín
Details
ALPS Touchpad picture -- Toshiba Satellite Pro M10 (bigger picture) (57.80 KB, image/jpeg)
2009-04-19 17:25 UTC, Pablo López Martín
Details
Add signature for Satellite Pro M10 (838 bytes, patch)
2009-04-21 02:41 UTC, Dmitry Torokhov
Details | Diff

Description Pablo López Martín 2009-04-18 01:30:15 UTC
Created attachment 21037 [details]
dmesg with i8042.debug kernel option

I'm using an ALPS Touchpad in my Toshiba Satellite Pro M10.
"Advanced features" in X like vertical/horizontal scrolling don't work
because kernel doesn't recognize the mouse as a touchpad but as a "PS/2
Generic Mouse". I've looked in launchpad/google/debian bugtrack systems
and this problem affects a lot of distros/hardware. All points it's a
problem with the input subsystem. I've seen reports of people that say
adding i8042.nomux=1 on boot fixes it for them. It doesn't for me. It's
not a hardware error (at least in my case) because touchpad works
flawless in windows.
Comment 1 Pablo López Martín 2009-04-18 01:30:54 UTC
Created attachment 21038 [details]
lspci -vv
Comment 2 Pablo López Martín 2009-04-18 01:31:53 UTC
Created attachment 21039 [details]
Output of cat /proc/bus/input/devices
Comment 3 Pablo López Martín 2009-04-18 01:32:23 UTC
Created attachment 21040 [details]
Output of lshal
Comment 4 Dmitry Torokhov 2009-04-19 08:01:08 UTC
Hmm, it looks like the touchpad has signature 0x32 0x02 0x14 which is not known by ALPS driver yet. Could you please describe your device (does it also have a trackpoint, additional buttons, etc)?
Comment 5 Pablo López Martín 2009-04-19 17:21:01 UTC
This touchpad has 4 physical buttons. A pair on the top and another pair on the bottom. Each pair is a left/right button combo. There is also a trackpoint in the middle of the keyboard between letters "F" and "G", but its use is optional. The touchpad section has a vertical and horizontal line painted to indicate the use of vertical/horizontal scrolling. I'm attaching a picture of it so you get a better idea of it.
Comment 6 Pablo López Martín 2009-04-19 17:22:53 UTC
Created attachment 21045 [details]
ALPS Touchpad picture -- Toshiba Satellite Pro M10
Comment 7 Pablo López Martín 2009-04-19 17:25:40 UTC
Created attachment 21046 [details]
ALPS Touchpad picture -- Toshiba Satellite Pro M10 (bigger picture)
Comment 8 Andrew Morton 2009-04-20 22:03:48 UTC
Which kernel version(s) worked OK?

Thanks.
Comment 9 Pablo López Martín 2009-04-20 22:24:06 UTC
I can't provide that information. This laptop has been recently installed 2 months ago. The previous OS was a Debian from about 4 years ago where the vertical/horizontal scrolling used to work. I didn't write down the previous kernel version and I did a clean install.
Comment 10 Dmitry Torokhov 2009-04-21 02:41:24 UTC
Created attachment 21062 [details]
Add signature for Satellite Pro M10

In-kernel ALPS driver never supported this particular version of the ALPS touchpad; I wonder if Slackware had some kind of user-level driver installed.

OK, let's try figure out how to driver this device. Pablo, please try this patch, if it does not work try removing ALPS_PASS and/or ALPS_DUALPOINT and see if any combination produces desired result. If nothing works then replace both flags with 0 and after booting with i8042.debug try working your touchpad a bit and send me the full dmesg. Thanks!
Comment 11 Pablo López Martín 2009-04-21 16:07:21 UTC
The patch works flawless as it is, without touching ALPS_PASS and/or ALPS_DUALPOINT and the touchpad gets correctly recognized as AlpsPS/2 ALPS DualPoint Touchpad :-) The synaptics module on X loads correctly and doesn't exit like it used to because it finds an ALPS Touchpad instead of a Generic PS/2 Mouse. Vertical and Horizontal scrolling works perfectly. All buttons work as expected.

Thanks a lot for your time Dmitry. Tell me if you need any more info.

Regards,

Pablo
Comment 12 Dmitry Torokhov 2009-04-24 05:13:00 UTC
Wow, got it on the first try, nice :) OK, I'll make sure the patch gets into 2.6.30. Thank you very much for testing.

Note You need to log in before you can comment on or make changes to this bug.