Bug 13126 - BUG: MAX_LOCKDEP_ENTRIES too low! when mounting rootfs
BUG: MAX_LOCKDEP_ENTRIES too low! when mounting rootfs
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-17 00:12 UTC by Rafael J. Wysocki
Modified: 2009-05-25 23:18 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc6
Tree: Mainline
Regression: Yes


Attachments
lockdep.c patch to be a little more informative when things bail out (2.37 KB, patch)
2009-04-26 23:33 UTC, Philip Copeland
Details | Diff

Description Rafael J. Wysocki 2009-04-17 00:12:47 UTC
Subject    : 2.6.30-rc2: BUG: MAX_LOCKDEP_ENTRIES too low! when mounting rootfs
Submitter  : Alexander Beregalov <a.beregalov@gmail.com>
Date       : 2009-04-15 12:43
References : http://marc.info/?l=linux-kernel&m=123979949820538&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Philip Copeland 2009-04-26 01:21:26 UTC
Seen with 2.6.30-rc3 as well
...
 device-mapper: multipath: version 1.0.5 loaded
 BUG: MAX_LOCKDEP_ENTRIES too low!
 turning off the locking correctness validator.
...

kernel/lockdep_internals.h:#define MAX_LOCKDEP_ENTRIES  8192UL

Phil
=--=
Comment 2 Philip Copeland 2009-04-26 01:54:40 UTC
even doubled to 16384UL it fell over,.. either something is eating locks or something extremely bad is happening

Phil
=--=
Comment 3 Philip Copeland 2009-04-26 23:28:23 UTC
Actually after talking with a few folk it seems that the whole lockdep system requirements have expanded massively since 2.6.20ish and no one has been bothered to resize the arrays accordingly

Incidentally it would be nice to actually spit out the sizes used rather than just 'too low'


Phil
=--=
Comment 4 Philip Copeland 2009-04-26 23:33:05 UTC
Created attachment 21128 [details]
lockdep.c patch to be a little more informative when things bail out

lockdep.c patch to be a little more informative when things bail out
'too low!' is extremely uninformative about what happened. esp as the values may change from kernel to kernel from what you might have expected
Comment 5 Rafael J. Wysocki 2009-05-13 10:52:27 UTC
Notify-Also : Philip Copeland <bryce@zeniv.linux.org.uk>
Comment 6 Alan 2009-05-21 19:12:22 UTC
Still present in rc6
Comment 7 Rafael J. Wysocki 2009-05-25 23:18:18 UTC
On Monday 25 May 2009, Peter Zijlstra wrote:
> On Sun, 2009-05-24 at 21:11 +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13126
> > Subject		: BUG: MAX_LOCKDEP_ENTRIES too low! when mounting rootfs
> > Submitter	: Alexander Beregalov <a.beregalov@gmail.com>
> > Date		: 2009-04-15 12:43 (40 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123979949820538&w=4
> 
> -rc7 includes:
> 
> Ingo Molnar (1):
>       lockdep: increase MAX_LOCKDEP_ENTRIES and MAX_LOCKDEP_CHAINS
> 
> Which can be found with commit id: 
>    d80c19df5fcceb8c741e96f09f275c2da719efef

Note You need to log in before you can comment on or make changes to this bug.