Bug 13124 - ioatdma: DMA-API: device driver frees DMA memory with wrong function
Summary: ioatdma: DMA-API: device driver frees DMA memory with wrong function
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_other
URL:
Keywords:
Depends on:
Blocks: 13070
  Show dependency tree
 
Reported: 2009-04-17 00:03 UTC by Rafael J. Wysocki
Modified: 2009-05-16 21:54 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-17 00:03:59 UTC
Subject    : 2.6.30-rc1: ioatdma: DMA-API: device driver frees DMA memory with wrong function
Submitter  : Alexander Beregalov <a.beregalov@gmail.com>
Date       : 2009-04-09 12:36
References : http://marc.info/?l=linux-kernel&m=123928064322503&w=4
Handled-By : Dan Williams <dan.j.williams@intel.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-04-26 17:48:17 UTC
On Sunday 26 April 2009, Alexander Beregalov wrote:
> 2009/4/25 Rafael J. Wysocki <rjw@sisk.pl>:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13124
> > Subject         : ioatdma: DMA-API: device driver frees DMA memory with
> wrong function
> > Submitter       : Alexander Beregalov <a.beregalov@gmail.com>
> > Date            : 2009-04-09 12:36 (17 days old)
> > References      : http://marc.info/?l=linux-kernel&m=123928064322503&w=4
> > Handled-By      : Dan Williams <dan.j.williams@intel.com>
> 
> Patch is available, http://patchwork.kernel.org/patch/19621/

Patch : http://patchwork.kernel.org/patch/19621/
Comment 2 Rafael J. Wysocki 2009-05-16 21:54:33 UTC
Fixed by commit 4f005dbe5584fe54c9f6d6d4f0acd3fb29be84da .

Note You need to log in before you can comment on or make changes to this bug.