Bug 13118 - iptables very slow after commit 784544739a25c30637397ace5489eeb6e15d7d49
Summary: iptables very slow after commit 784544739a25c30637397ace5489eeb6e15d7d49
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Netfilter/Iptables (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_netfilter-iptables@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 13070
  Show dependency tree
 
Reported: 2009-04-16 23:28 UTC by Rafael J. Wysocki
Modified: 2009-05-17 10:25 UTC (History)
0 users

See Also:
Kernel Version: commit 784544739a25c30637397ace5489eeb6e15d7d49
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-16 23:28:20 UTC
Subject    : iptables very slow after commit 784544739a25c30637397ace5489eeb6e15d7d49
Submitter  : Jeff Chua <jeff.chua.linux@gmail.com>
Date       : 2009-04-10 16:05
References : http://lkml.org/lkml/2009/4/10/111
Handled-By : Eric Dumazet <dada1@cosmosbay.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 784544739a25c30637397ace5489eeb6e15d7d49
Author: Stephen Hemminger <shemminger@vyatta.com>
Date:   Fri Feb 20 10:35:32 2009 +0100

    netfilter: iptables: lock free counters

    Acked-by: Eric Dumazet <dada1@cosmosbay.com>
    Signed-off-by: Patrick McHardy <kaber@trash.net>
Comment 1 Rafael J. Wysocki 2009-04-26 12:09:04 UTC
On Sunday 26 April 2009, Jeff Chua wrote:
> On Sun, Apr 26, 2009 at 3:31 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13118
> > Subject         : iptables very slow after commit
> 784544739a25c30637397ace5489eeb6e15d7d49
> > Submitter       : Jeff Chua <jeff.chua.linux@gmail.com>
> > Date            : 2009-04-10 16:05 (16 days old)
> > References      : http://lkml.org/lkml/2009/4/10/111
> > Handled-By      : Eric Dumazet <dada1@cosmosbay.com>
> 
> Several iteration of patches are in progress. Latest one being
> http://lkml.org/lkml/2009/4/25/83

References : http://lkml.org/lkml/2009/4/25/83
Comment 2 Rafael J. Wysocki 2009-05-17 10:16:20 UTC
On Sunday 17 May 2009, Jeff Chua wrote:
> On Sun, May 17, 2009 at 3:20 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=13118
> > Subject         : iptables very slow after commit
> 784544739a25c30637397ace5489eeb6e15d7d49
> > Submitter       : Jeff Chua <jeff.chua.linux@gmail.com>
> > Date            : 2009-04-10 16:05 (37 days old)
> > References      : http://lkml.org/lkml/2009/4/10/111
> >                  http://lkml.org/lkml/2009/4/25/83
> > Handled-By      : Eric Dumazet <dada1@cosmosbay.com>
> 
> Fixed as of Apr 28.
> 
> commit 942e4a2bd680c606af0211e64eb216be2e19bf61
> Author: Stephen Hemminger <shemminger@vyatta.com>
> Date:   Tue Apr 28 22:36:33 2009 -0700
> 
>     netfilter: revised locking for x_tables

Note You need to log in before you can comment on or make changes to this bug.