Bug 13116 - Can't boot with nosmp
Can't boot with nosmp
Status: CLOSED CODE_FIX
Product: Virtualization
Classification: Unclassified
Component: kvm
All Linux
: P1 normal
Assigned To: virtualization_kvm
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-16 23:12 UTC by Rafael J. Wysocki
Modified: 2009-06-09 23:18 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-16 23:12:31 UTC
Subject    : Can't boot with "nosmp"
Submitter  : Stephen Hemminger <shemminger@vyatta.com>
Date       : 2009-04-15 4:18
References : http://marc.info/?l=linux-kernel&m=123976917817920&w=4
Handled-By : Dan Williams <dan.j.williams@intel.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-06-08 18:12:55 UTC
References : http://lkml.org/lkml/2009/6/8/301
Comment 2 Rafael J. Wysocki 2009-06-09 23:18:24 UTC
On Tuesday 09 June 2009, Stephen Hemminger wrote:
> On Tue, 09 Jun 2009 21:42:55 +0300
> Avi Kivity <avi@redhat.com> wrote:
> 
> > Stephen Hemminger wrote:
> > 
> >   
> > 
> > >> This only affects reboots.  But yes, the cpumask code has bugs.  Does 
> > >> the .config involved select MAXSMP?
> > >>
> > >>     
> > >
> > > Patch does not fix the problem. Not sure if it is KVM only problem.
> > > Look like possible cpumask always equals what ACPI / SMP tables report.
> > > So currently looking into alloc_percpu which may not handle the possible
> > > but never used cpus.
> > >
> > >   
> > 
> > Right, it shouldn't have.
> > 
> > > It is x86-64 config and does not have MAXSMP set. It does have NR_CPUS set.
> > >   
> > 
> > So it's not cpumask.  Dare I suggest a bisect?
> > 
> 
> I did some testing of different versions.
> 
> * Problem does not exist with 2.6.30-rc8 (so regression should be closed).
> 
> * Problem does exist with 2.6.29.4
> 
> * Happens with both nosmp and maxcpus=1

Note You need to log in before you can comment on or make changes to this bug.