Bug 13111 - Linux 2.6.30-rc1 tg3 endian issues with MAC addresses on BCM5701
Linux 2.6.30-rc1 tg3 endian issues with MAC addresses on BCM5701
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-16 21:49 UTC by Rafael J. Wysocki
Modified: 2009-04-26 12:06 UTC (History)
0 users

See Also:
Kernel Version: 2.6.30-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-16 21:49:43 UTC
Subject    : Linux 2.6.30-rc1 tg3 endian issues with MAC addresses on BCM5701.  Bisected.
Submitter  : Robin Holt <holt@sgi.com>
Date       : 2009-04-08 7:12
References : http://marc.info/?l=linux-kernel&m=123917477312823&w=4
Handled-By : "Matt Carlson" <mcarlson@broadcom.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit e4f341103e4a2b35f56a0f89802f1b1448e8d04b
Author: Matt Carlson <mcarlson@broadcom.com>
Date:   Wed Feb 25 14:25:00 2009 +0000

    tg3: Invert nvram_read() and nvram_read_swab()

    Signed-off-by: Matt Carlson <mcarlson@broadcom.com>
    Signed-off-by: Benjamin Li <benli@broadcom.com>
    Signed-off-by: Michael Chan <mchan@broadcom.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>

First-Bad-Commit : e4f341103e4a2b35f56a0f89802f1b1448e8d04b
Comment 1 Rafael J. Wysocki 2009-04-17 21:19:50 UTC
References : http://lkml.org/lkml/2009/4/16/471
Comment 2 Rafael J. Wysocki 2009-04-26 12:06:42 UTC
Fixed by commit 62cedd11f63c99efd2962fb69763a09e2778f6e6 .

Note You need to log in before you can comment on or make changes to this bug.