Bug 13107 - LTP 20080131 causes defunct processes w/2.6.30-rc1
Summary: LTP 20080131 causes defunct processes w/2.6.30-rc1
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: process_other
URL:
Keywords:
Depends on:
Blocks: 13070
  Show dependency tree
 
Reported: 2009-04-16 21:27 UTC by Rafael J. Wysocki
Modified: 2009-05-23 00:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.30-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-16 21:27:48 UTC
Subject    : LTP 20080131 causes defunct processes w/2.6.30-rc1 (possible ptrace issue?)
Submitter  : Kumar Gala <galak@kernel.crashing.org>
Date       : 2009-04-09 15:43
References : http://marc.info/?l=linux-kernel&m=123929187208953&w=4
Handled-By : Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit b3bfa0cba867f23365b81658b47efd906830879b
Author: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
Date:   Thu Apr 2 16:58:08 2009 -0700

     signals: protect cinit from blocked fatal signals

     Signed-off-by: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
     Cc: Oleg Nesterov <oleg@tv-sign.ru>
     Cc: Roland McGrath <roland@redhat.com>
     Cc: "Eric W. Biederman" <ebiederm@xmission.com>
     Cc: Daniel Lezcano <daniel.lezcano@free.fr>
     Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
     Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

First-Bad-Commit : b3bfa0cba867f23365b81658b47efd906830879b
Comment 1 Rafael J. Wysocki 2009-04-17 21:17:38 UTC
References : http://lkml.org/lkml/2009/4/10/193
Comment 2 Rafael J. Wysocki 2009-05-13 10:44:52 UTC
Notify-Also : Oleg Nesterov <oleg@tv-sign.ru>
Comment 3 Rafael J. Wysocki 2009-05-18 17:24:12 UTC
References : http://lkml.org/lkml/2009/5/17/149
Comment 4 Alan 2009-05-21 20:49:42 UTC
Linus - "People convinced me it wasn't really a regression. LTP has already been 
changed, and there are people out there who actually want to stop init for 
debugging etc."
Comment 5 Rafael J. Wysocki 2009-05-23 00:06:07 UTC
On Friday 22 May 2009, Linus Torvalds wrote:
> 
> On Sat, 16 May 2009, Rafael J. Wysocki wrote:
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=13107
> > Subject             : LTP 20080131 causes defunct processes w/2.6.30-rc1
> > Submitter   : Kumar Gala <galak@kernel.crashing.org>
> > Date                : 2009-04-09 15:43 (38 days old)
> > Handled-By  : Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>
> 
> This one seems to have become "not-a-bug". Yes, LTP used to check that you 
> cannot send SIGSTP to init, but people do want to send signals to init 
> (especially when they are inside pid-namespace containers), and as long as 
> it's only a LTP test that already got modified (and not some actual 
> real-life usage), I'm considering this a "test failed because it was 
> testing for behavior that we want to change" at least for now.

Note You need to log in before you can comment on or make changes to this bug.