Bug 13094 - Thinkpad X40 randomly hangs while booting.
Summary: Thinkpad X40 randomly hangs while booting.
Status: CLOSED DUPLICATE of bug 13087
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ykzhao
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-15 21:25 UTC by Daniel Vetter
Modified: 2009-04-24 05:22 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.29-rc2
Tree: Mainline
Regression: Yes


Attachments
my .config (57.17 KB, text/plain)
2009-04-15 21:25 UTC, Daniel Vetter
Details

Description Daniel Vetter 2009-04-15 21:25:46 UTC
Created attachment 21003 [details]
my .config

Hardware: Thinkpad X40 Laptop, Pentium M 1.2 GHz, Bios v2.07
Software: Debian unstable x86_32

When booting up 2.6.29-rc2, the system hangs hard somewhat randomly (usually when loading kernel modules). No reaction to sysrq. I used bisecting to track down the problem to the following commit

commit ff69f2bba67bd45514923aaedbf40fe351787c59
Author: alex.shi <alex.shi@intel.com>
Date:   Wed Mar 4 11:55:26 2009 -0800

    acpi: fix of pmtimer overflow that make Cx states time incorrect

Reverting this on top of 2.6.29-rc2 gets rid of the hangs. I'll attach my config. 2.6.29 is not affected, so this is a post-2.6.29 regression.
Comment 1 Andrew Morton 2009-04-15 21:47:27 UTC
2.6.29-rc2 is a funny kernel version to be testing: -rc2 is always full
of regressions.

Is the bug also present in 2.6.29 final?

Thanks.
Comment 2 Alex Shi 2009-04-16 01:36:09 UTC
it is duplicated with bug 13087, but I did not found some ways set this as previous bugzilla.  :(
Comment 3 ykzhao 2009-04-16 02:17:10 UTC
Hi, Alex
    What you said is right. It is the duplicate bug of 13087.
    
    Will you please try the boot option of "clocksource=acpi_pm" and see whether the box still hangs?
    Thanks.
Comment 4 ykzhao 2009-04-16 02:19:48 UTC
Hi, Daniel
    Will you please try the boot option of "clocksource=acpi_pm" and see whether the box still hangs?
    
    Do you mean that the system can be booted normally if the following commit is reverted on the latest git-tree?
    >ff69f2bba67bd45514923aaedbf40fe351787c59


    thanks.
Comment 5 Zhang Rui 2009-04-16 03:23:17 UTC

*** This bug has been marked as a duplicate of bug 13087 ***
Comment 6 Daniel Vetter 2009-04-16 08:41:26 UTC
On Thu, Apr 16, 2009 at 02:19:48AM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:
> --- Comment #4 from ykzhao <yakui.zhao@intel.com>  2009-04-16 02:19:48 ---
> Hi, Daniel
>     Will you please try the boot option of "clocksource=acpi_pm" and see
> whether the box still hangs?

I've just tested and yes, it works with on 2.6.30-rc2 (sorry for yet again
screwing up the version numbers - when bisecting I'm always confused by
the fact that the git versions starts with with the old version number
(2.6.29) before rc1).

>     Do you mean that the system can be booted normally if the following
>     commit
> is reverted on the latest git-tree?
>     >ff69f2bba67bd45514923aaedbf40fe351787c59

Yes, reverting ff69.. on top of 2.6.30-rc2 fixes the hangs, too.

Thanks, Daniel

Note You need to log in before you can comment on or make changes to this bug.