Bug 13089 - ACPI: I/O resource ... conflicts with ACPI region ...
Summary: ACPI: I/O resource ... conflicts with ACPI region ...
Status: CLOSED DUPLICATE of bug 12376
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ykzhao
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-15 11:47 UTC by Liontos Aristotelis
Modified: 2009-04-15 14:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29.1
Tree: Mainline
Regression: No


Attachments
dmesg lspci acpidump ioports (150.00 KB, application/x-tar)
2009-04-15 11:50 UTC, Liontos Aristotelis
Details

Description Liontos Aristotelis 2009-04-15 11:47:45 UTC
Tyan Thunder K8W S2885,Bios version 2.08,1gb memory installed
http://tyan.com/support_download_bios.aspx?model=S.S2885

Fresh installed Debian testing x86_64.Numa is enabled.The system runs fine but i get this error

[   13.178029] ACPI: I/O resource 0000:00:07.2 [0xcc00-0xcc1f] conflicts with ACPI region ECIO [0xcc00-0xcc1f]
[   13.215721] ACPI: Device needs an ACPI driver
[   13.280228] ACPI: I/O resource amd756_smbus [0x10e0-0x10ef] conflicts with ACPI region PMIO [0x1000-0x10fe]
[   13.318786] ACPI: Device needs an ACPI driver
Comment 1 Liontos Aristotelis 2009-04-15 11:50:34 UTC
Created attachment 20989 [details]
dmesg lspci acpidump ioports
Comment 2 ykzhao 2009-04-15 13:00:34 UTC
Will you please try the patch in 
http://bugzilla.kernel.org/show_bug.cgi?id=12376#C45 ?
    
In fact the above message is correct. It reports the potential risk. 
The ECIO(0xcc00-cc1f) is defined in ACPI AML code and it will be accessed. In such case we had better load the I2C driver for the SMbus PCI device.

Thanks.
Comment 3 ykzhao 2009-04-15 13:01:00 UTC
Will you please try the patch in 
http://bugzilla.kernel.org/show_bug.cgi?id=12376#C45 ?
    
In fact the above message is correct. It reports the potential risk. 
The ECIO(0xcc00-cc1f) is defined in ACPI AML code and it will be accessed. In such case we had better load the I2C driver for the SMbus PCI device.

Thanks.
Comment 4 ykzhao 2009-04-15 13:04:54 UTC
The patch in http://bugzilla.kernel.org/show_bug.cgi?id=12376#c45 is already shipped in acpi-test tree. 

So this bug will be marked as the duplicate of bug12376.

Thanks.

*** This bug has been marked as a duplicate of bug 12376 ***

Note You need to log in before you can comment on or make changes to this bug.