Bug 13076 - Fn + brightness up/down keys doesn't work if ACPI enabled - Samsung NC20
Fn + brightness up/down keys doesn't work if ACPI enabled - Samsung NC20
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 23:34 UTC by Barry Carroll
Modified: 2009-09-05 05:22 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-11
Tree: Mainline
Regression: No


Attachments
dmesg output (36.16 KB, text/plain)
2009-04-12 23:34 UTC, Barry Carroll
Details
lspci output (11.38 KB, text/plain)
2009-04-12 23:34 UTC, Barry Carroll
Details
patch for atkbd.c to add nc20 forced release keys (789 bytes, patch)
2009-04-12 23:36 UTC, Barry Carroll
Details | Diff

Description Barry Carroll 2009-04-12 23:34:06 UTC
Created attachment 20950 [details]
dmesg output

This bug is similar to most new samsung laptops including the NC10 which is addressed in bug 12021

http://bugzilla.kernel.org/show_bug.cgi?id=12021

I have created a bug report downstream in the Ubuntu bug tracker:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/360247

Distribution: Ubuntu Jaunty Beta
Kernel: 2.6.28-11

Steps to reproduce:
===================
Press fn key plus up arrow to increase brightness, press fn key plus down arrow to decrease brightness

Expected results
================
Screen brightness is increased or decreased 

Actual results
==============
fn plus down arrow reduces brightness to minimum.
fn plus up arrow increases brightness to maximum.
Gnome interface becomes unusable: menus cannot be clicked, keyboard becomes unresponsive

Comments
========
The behaviour observed is because the key release events after brightness up and brightness down are not generated.  This has the effect of repeating the brightness up or brightness down keys indefinitely.  This causes the "all or nothing" effect on brightness and the unresponsive Gnome GUI.
Comment 1 Barry Carroll 2009-04-12 23:34:58 UTC
Created attachment 20951 [details]
lspci output
Comment 2 Barry Carroll 2009-04-12 23:36:22 UTC
Created attachment 20952 [details]
patch for atkbd.c to add nc20 forced release keys
Comment 3 Barry Carroll 2009-04-12 23:37:01 UTC
Added patch which I have tested to fix the problem on my machine.
Comment 4 Dmitry Torokhov 2009-04-13 00:24:18 UTC
Barry,

Thank you very much for the patch. Can I please have your "Signed-off-by: ..." so I can apply it and make sure it gets into 2.6.30? Thanks!
Comment 5 Barry Carroll 2009-04-13 10:10:17 UTC
Hi Dmitry,

That sounds great, thanks.  This is my first patch so I'm unsure about "Signed-off-by".  Hopefully it's just the following, but let me know if you need me to do anything else!

Signed-off-by: Barry Carroll <baz8080@gmail.com>

Thanks again,

Barry.
Comment 6 Dmitry Torokhov 2009-04-13 16:41:59 UTC
Yep, that is it. It just certifies that your patch conforms to the following:

http://elinux.org/Developer_Certificate_Of_Origin
Comment 7 Barry Carroll 2009-04-13 18:22:33 UTC
Thanks for the link, I read through it and everything is in order.
Comment 8 Dmitry Torokhov 2009-09-05 05:22:35 UTC
Patch is in mainline, closing.

Note You need to log in before you can comment on or make changes to this bug.