Bug 13072 - forcedeth seems to switch off eth on shutdown
Summary: forcedeth seems to switch off eth on shutdown
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 12398
  Show dependency tree
 
Reported: 2009-04-12 07:00 UTC by Daniel Bierstedt
Modified: 2009-06-10 20:06 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.29.1
Tree: Mainline
Regression: No


Attachments

Description Daniel Bierstedt 2009-04-12 07:00:54 UTC
Hello,

I've built a vanilla 2.6.29.1 on a Debian Lenny (stable) system. After recognizing that I will not get lirc working on 2.6.29, I wanted to switch back to 2.6.28.9. But on any other kernel than 2.6.29.1, the network interface is down (no led's no link).
Ifconfig on 2.6.28.9 is reporting "no link" for eth0, so the driver seems to be loaded fine...

The forcedeth from 2.6.29.1 seems to "shut down" the interface on shutdown, so no other kernel can use it.
Comment 1 Andrew Morton 2009-04-15 00:05:49 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Sun, 12 Apr 2009 07:00:54 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=13072
> 
>            Summary: forcedeth seems to switch off eth on shutdown
>            Product: Drivers
>            Version: 2.5
>     Kernel Version: 2.6.29.1
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Network
>         AssignedTo: drivers_network@kernel-bugs.osdl.org
>         ReportedBy: daniel.bierstedt@gmx.de
>         Regression: No
> 
> 
> Hello,
> 
> I've built a vanilla 2.6.29.1 on a Debian Lenny (stable) system. After
> recognizing that I will not get lirc working on 2.6.29, I wanted to switch
> back
> to 2.6.28.9. But on any other kernel than 2.6.29.1, the network interface is
> down (no led's no link).
> Ifconfig on 2.6.28.9 is reporting "no link" for eth0, so the driver seems to
> be
> loaded fine...
> 
> The forcedeth from 2.6.29.1 seems to "shut down" the interface on shutdown,
> so
> no other kernel can use it.
> 

Seems to be a 2.6.28->2.6.29 regression.
Comment 2 Rafael J. Wysocki 2009-04-26 23:20:21 UTC
On Sunday 26 April 2009, Daniel Bierstedt wrote:
> Hello,
> 
> yes, this bug entry should be listed. This bug prevents people from
> using live-cd's or testing the 2.6.29 (if they know about this bug...).
> 
> 
> Am Sonntag, den 26.04.2009, 11:46 +0200 schrieb Rafael J. Wysocki:
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.28 and 2.6.29.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=13072
> > Subject             : forcedeth seems to switch off eth on shutdown
> > Submitter   : Daniel Bierstedt <daniel.bierstedt@gmx.de>
> > Date                : 2009-04-12 07:00 (15 days old)
Comment 3 Rafael J. Wysocki 2009-05-17 12:57:26 UTC
On Sunday 17 May 2009, Daniel Bierstedt wrote:
> Hello,
> 
> as I wrote on 26'th of April:
> 
> yes, this bug entry should be listed. This bug prevents people from
> using live-cd's or testing the 2.6.29 (if they know about this bug...).
> 
> Meanwhile I did some tests with knoppix 6 (2.6.28.4) and the
> systemrescue-cd (2.6.27.somewhat). Both could deal with eth0, but the
> physical device remained dead...
> 
> 
> 
> Am Samstag, den 16.05.2009, 22:06 +0200 schrieb Rafael J. Wysocki: 
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.28 and 2.6.29.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=13072
> > Subject             : forcedeth seems to switch off eth on shutdown
> > Submitter   : Daniel Bierstedt <daniel.bierstedt@gmx.de>
> > Date                : 2009-04-12 07:00 (35 days old)
Comment 4 Ayaz Abdulla 2009-05-18 16:24:26 UTC
Daniel,

Do you see this problem on the latest kernel?
Comment 5 Daniel Bierstedt 2009-05-18 17:02:19 UTC
Hello,

I will test 2.6.29.3 this week, some free time.


Am Montag, den 18.05.2009, 16:24 +0000 schrieb
bugzilla-daemon@bugzilla.kernel.org:

> http://bugzilla.kernel.org/show_bug.cgi?id=13072
> 
> 
> Ayaz Abdulla <aabdulla@nvidia.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |aabdulla@nvidia.com
> 
> 
> 
> 
> --- Comment #4 from Ayaz Abdulla <aabdulla@nvidia.com>  2009-05-18 16:24:26
> ---
> Daniel,
> 
> Do you see this problem on the latest kernel?
>
Comment 6 Ayaz Abdulla 2009-05-18 17:34:02 UTC
I double checked the differences between 28.9 vs. 29.1. There is a new phy powerdown feature added to 29.1. Therefore, if you go from 29.1 to 28.9, there will be no link as 28.9 does not have the logic to take the phy out of powerdown mode.

You need to power cycle your system to get the link back if you are not going to use 29.1 and above.
Comment 7 Daniel Bierstedt 2009-05-20 09:04:24 UTC
Hello,

first the good one:
    you are right, completely removing the power plug makes the eth
device available again

second the bad one:
    29.3 has this problem, too. "latest" meant the latest stable kernel,
no?


Am Montag, den 18.05.2009, 17:34 +0000 schrieb
bugzilla-daemon@bugzilla.kernel.org:

> http://bugzilla.kernel.org/show_bug.cgi?id=13072
> 
> 
> 
> 
> 
> --- Comment #6 from Ayaz Abdulla <aabdulla@nvidia.com>  2009-05-18 17:34:02
> ---
> I double checked the differences between 28.9 vs. 29.1. There is a new phy
> powerdown feature added to 29.1. Therefore, if you go from 29.1 to 28.9,
> there
> will be no link as 28.9 does not have the logic to take the phy out of
> powerdown mode.
> 
> You need to power cycle your system to get the link back if you are not going
> to use 29.1 and above.
>
Comment 8 Ayaz Abdulla 2009-05-20 19:23:50 UTC
When you say that 29.3 has this problem too, you mean the problem occurs when going from 29.3 to 28.9 right?

This can not be fixed, as 29.xx has put the phy into low power (new feature in driver) that the older driver 28.xx does not know about and therefore does not have the code to take it out of low power.
Comment 9 Daniel Bierstedt 2009-05-21 18:59:34 UTC
Hey,

you are right, any other than .29 Kernel has this problem.

So, it's not a bug, it's a feature? Hey, Bill, is that you?? How's
weather in Redmond?


But ok, thanks for the info. Since I know about pulling the power plug,
this problem is not so serious to me, just a question of comfort. But
what is the reason? I did not notice this change in the changelogs for
2.6.29. Low power sounds like green IT?


Am Mittwoch, den 20.05.2009, 19:23 +0000 schrieb
bugzilla-daemon@bugzilla.kernel.org:

> http://bugzilla.kernel.org/show_bug.cgi?id=13072
> 
> 
> 
> 
> 
> --- Comment #8 from Ayaz Abdulla <aabdulla@nvidia.com>  2009-05-20 19:23:50
> ---
> When you say that 29.3 has this problem too, you mean the problem occurs when
> going from 29.3 to 28.9 right?
> 
> This can not be fixed, as 29.xx has put the phy into low power (new feature
> in
> driver) that the older driver 28.xx does not know about and therefore does
> not
> have the code to take it out of low power.
>
Comment 10 Chuck Ebbert 2009-05-22 20:09:54 UTC
> This can not be fixed, as 29.xx has put the phy into low power (new feature
> in
> driver) that the older driver 28.xx does not know about and therefore does
> not
> have the code to take it out of low power.

Users dual-booting Windows have this problem too, and there's even a report from someone with a BIOS that has a link-testing feature who has hit it.

Is this going to be left this way? Fedora has had to revert the power-down change rather that deal with a flood of bug reports about this.
Comment 11 Ayaz Abdulla 2009-05-27 23:44:45 UTC
I don't see what can be done here. New driver is turning on a feature (i.e power saving feature). The old driver is already out in the wild and doesn't have code to handle the new feature.

Chuck, are you saying that the Windows driver can not take the phy out of low power?
Comment 12 Chuck Ebbert 2009-06-01 18:04:40 UTC
> Chuck, are you saying that the Windows driver can not take the phy out of low
> power?

Yes, it breaks Windows too.

We just got a bug report that says: "The Fedora preview fried my ethernet card." The user replaced his onboard adapter with an add-on card...
Comment 13 Ayaz Abdulla 2009-06-04 00:59:17 UTC
Chuck,

A new patch has been created by Ed Swierk which does not turn on this feature by default. User needs to explicitly use this feature with module params.

This should help with backwards compatibility issues.
Comment 14 Rafael J. Wysocki 2009-06-07 20:48:28 UTC
Fixed by commit 5a9a8e32ebe269c71d8d3e78f9435fe7729f38e9 .
Comment 15 Daniel Bierstedt 2009-06-10 20:06:57 UTC
Rafael,

thank you very much!


Am Sonntag, den 07.06.2009, 20:48 +0000 schrieb
bugzilla-daemon@bugzilla.kernel.org:

> http://bugzilla.kernel.org/show_bug.cgi?id=13072
> 
> 
> Rafael J. Wysocki <rjw@sisk.pl> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|NEW                         |RESOLVED
>          Resolution|                            |CODE_FIX
> 
> 
> 
> 
> --- Comment #14 from Rafael J. Wysocki <rjw@sisk.pl>  2009-06-07 20:48:28 ---
> Fixed by commit 5a9a8e32ebe269c71d8d3e78f9435fe7729f38e9 .
>

Note You need to log in before you can comment on or make changes to this bug.