Bug 13067 - iwl3945: wlan0: beacon loss from AP - sending probe request
iwl3945: wlan0: beacon loss from AP - sending probe request
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-11 20:24 UTC by Rafael J. Wysocki
Modified: 2009-05-07 11:30 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29-git12
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-04-11 20:24:09 UTC
Subject    : [2.6.29-git12 iwl3945] wlan0: beacon loss from AP 00:19:5b:e7:a2:f8 - sending probe request
Submitter  : Maciej Rutecki <maciej.rutecki@gmail.com>
Date       : 2009-04-05 9:11
References : http://marc.info/?l=linux-kernel&m=123892272218266&w=4

This entry is being used for tracking a regression from 2.6.29.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 John W. Linville 2009-04-16 18:15:06 UTC
This might relate to the problem Marcel was describing about disassociation during scans?
Comment 2 Reinette Chatre 2009-04-16 20:19:36 UTC
This report appears to be a complaint of the presence of the message " beacon loss from AP 00:19:5b:e7:a2:f8 - sending probe request" and not any problems with the connection self.

There was a patch to post this message only if debug is enabled, see 72ac470d663b4cd5e66247a4307f09ac4e519320 "mac80211: quiet beacon loss messages" ... perhaps this patch can go to 2.6.30?
Comment 3 John W. Linville 2009-04-17 14:58:40 UTC
Yes, I intend to send that one soon.
Comment 4 Rafael J. Wysocki 2009-04-17 21:08:52 UTC
On Friday 17 April 2009, Justin Madru wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.29.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13067
> > Subject		: iwl3945: wlan0: beacon loss from AP - sending probe request
> > Submitter	: Maciej Rutecki <maciej.rutecki@gmail.com>
> > Date		: 2009-04-05 9:11 (12 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123892272218266&w=4
> >
> >
> >   
> I'm getting this on .30rc2, so I confirm that it's still an issue (I'm 
> not the original submitter).
> It's really annoying because it's filling my logs like crazy. Below is 
> 15mins of logs, and it just repeats like this.
> 
> dhclient: DHCPREQUEST of 192.168.1.5 on wlan0 to 192.168.1.254 port 67
> dhclient: DHCPACK of 192.168.1.5 from 192.168.1.254
> dhclient: bound to 192.168.1.5 -- renewal in 823 seconds.
> NetworkManager: <debug> [1239937333.003788] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239937339.001004] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> NetworkManager: <debug> [1239937453.002911] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239937459.000974] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> NetworkManager: <debug> [1239937573.002956] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239937579.000971] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> NetworkManager: <debug> [1239937693.003787] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239937699.000981] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> NetworkManager: <debug> [1239937813.002710] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239937819.000753] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> NetworkManager: <debug> [1239937933.003806] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239937939.000724] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> NetworkManager: <debug> [1239938053.002711] periodic_update(): Roamed 
> from BSSID 00:1C:DF:67:1F:AC (madru) to (none) ((none))
> kernel: wlan0: beacon loss from AP 00:1c:df:67:1f:ac - sending probe request
> NetworkManager: <debug> [1239938059.001749] periodic_update(): Roamed 
> from BSSID (none) ((none)) to 00:1C:DF:67:1F:AC (madru)
> dhclient: DHCPREQUEST of 192.168.1.5 on wlan0 to 192.168.1.254 port 67
> dhclient: DHCPACK of 192.168.1.5 from 192.168.1.254
> dhclient: bound to 192.168.1.5 -- renewal in 803 seconds.
Comment 5 sirius 2009-04-23 10:16:45 UTC
Cannot confirm iwconfig showing slow bit rate like mentioned in first post, but the message is still there in 30-rc3. It's spitted out every 120 seconds (+/-1) - is the beacon loss intentional/expected?
Comment 6 Kalle Valo 2009-04-25 06:44:06 UTC
John told me that the patches fixing this are in net-2.6 and hopefully they will make it to 2.6.30-rc4:

mac80211: quiet beacon loss messages
http://git.kernel.org/?p=linux/kernel/git/davem/net-2.6.git;a=commit;h=a860402d8f1756dae48cdcabe153c974116fc37e

mac80211: fix beacon loss detection after scan
http://git.kernel.org/?p=linux/kernel/git/davem/net-2.6.git;a=commit;h=ad935687dbe7307f5abd9e3f610a965a287324a9
Comment 7 Rafael J. Wysocki 2009-04-25 20:14:44 UTC
On Friday 24 April 2009, Niel Lambrechts wrote:
> >   
> Just to let you know, this is still present in 2.6.30-rc3:
> 
> Apr 24 01:19:20 linux-7vph kernel: wlan0: beacon loss from AP
> 00:1d:92:1d:1e:8e - sending probe request
> Apr 24 01:19:58 linux-7vph kernel: wlan0: beacon loss from AP
> 00:1d:92:1d:1e:8e - sending probe request
> Apr 24 01:20:57 linux-7vph kernel: wlan0: beacon loss from AP
> 00:1d:92:1d:1e:8e - sending probe request
> Apr 24 01:22:19 linux-7vph kernel: wlan0: beacon loss from AP
> 00:1d:92:1d:1e:8e - sending probe request
Comment 8 Rafael J. Wysocki 2009-04-25 21:33:38 UTC
Patch : http://bugzilla.kernel.org/show_bug.cgi?id=13067#c6
Comment 9 sirius 2009-05-07 10:00:59 UTC
Seems fixed in 2.6.30-rc4.

Note You need to log in before you can comment on or make changes to this bug.