Bug 13063 - Devicemapper fails to load/initialise, root filesystem can not be accessed
Devicemapper fails to load/initialise, root filesystem can not be accessed
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 high
Assigned To: Jens Axboe
:
: 13044 (view as bug list)
Depends on:
Blocks: 13070
  Show dependency treegraph
 
Reported: 2009-04-11 12:35 UTC by Heinz Diehl
Modified: 2009-04-14 17:26 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30-rc1|-git
Tree: Mainline
Regression: Yes


Attachments
Ingo Molnar's reversion (5.30 KB, patch)
2009-04-11 12:35 UTC, Heinz Diehl
Details | Diff
Screencopy (215.03 KB, image/jpeg)
2009-04-11 12:37 UTC, Heinz Diehl
Details

Description Heinz Diehl 2009-04-11 12:35:35 UTC
Created attachment 20936 [details]
Ingo Molnar's reversion

Hi,

I have a machine which has a LUKS/dmcrypt encrypted root fs. Booting a 2.6.30-rc/git kernel (and also 2.6.29-git15), the root fs can not be mounted any longer, and the system boots into /bin/sh. The cause seems to be that the device-mapper can not be initialised before the root fs is going to be mounted at bootup, caused by the async boot process. I don't know...

This happens both on openSuSE and Fedora laptops too, which have an encrypted root fs, my wife has one.

The solution is to revert 
"9710794: async: remove the temporary (2.6.29) "async is off by default"

I've attached the reversion, posted by Ingo Molnar som days ago, which was the fix for a bug which is unrelated to this one, and also a screencopy. Unfortunately, without any root fs available, I can't provide more information.

If 9710794 goes into mainline, it breaks all systems which have encrypted root fs.

Regards, Heinz.
Comment 1 Heinz Diehl 2009-04-11 12:37:36 UTC
Created attachment 20937 [details]
Screencopy
Comment 2 Heinz Diehl 2009-04-11 21:01:50 UTC
*** Bug 13044 has been marked as a duplicate of this bug. ***
Comment 3 Len Brown 2009-04-14 15:41:30 UTC
commit    d6de2c80e9d758d2e36c21699117db6178c0f517
"async: Fix module loading async-work regression"

is now in Linus' tree (before 2.6.30-rc1-git7) and should fix this.
please re-open if it does not.
Comment 4 Heinz Diehl 2009-04-14 17:26:40 UTC
Yes, that fixed it. Thanks!

Note You need to log in before you can comment on or make changes to this bug.