Bug 13040 - DRM radeon
DRM radeon
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-04-07 20:07 UTC by Roger Luethi
Modified: 2010-09-22 17:45 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29.1
Tree: Mainline
Regression: Yes


Attachments
boot messages (Vanilla Linux 2.6.29.1) (47.35 KB, text/plain)
2009-04-07 20:07 UTC, Roger Luethi
Details
X Server log (39.94 KB, text/plain)
2009-04-07 20:09 UTC, Roger Luethi
Details

Description Roger Luethi 2009-04-07 20:07:47 UTC
Created attachment 20864 [details]
boot messages (Vanilla Linux 2.6.29.1)

I've been having all kinds of interesting errors with radeon DRM since 2.6.28 (and I filed one report, bug 12333).

With 2.6.29.1, a new X.org server (1.4.2->1.5.3) and a new ATI driver (6.9.0 -> 6.12.1), DRM is not working and I am getting these infos:

In dmesg:
[  160.613947] =======================================================
[  160.613951] [ INFO: possible circular locking dependency detected ]
[  160.613953] 2.6.29.1-01 #1
[  160.613955] -------------------------------------------------------
[  160.613958] X/8820 is trying to acquire lock:
[  160.613960]  (&dev->struct_mutex){--..}, at: [<f879445a>] drm_mmap+0x25/0x3f [drm]
[  160.613986]
[  160.613986] but task is already holding lock:
[  160.613989]  (&mm->mmap_sem){----}, at: [<c0106619>] sys_mmap2+0x44/0x7b
[  160.613997]
[  160.613997] which lock already depends on the new lock.

And in Xorg.0.log:

(II) RADEON(0): [drm] installed DRM signal handler
(EE) RADEON(0): [pci] Out of memory (-12)
(EE) RADEON(0): [pci] PCI failed to initialize. Disabling the DRI.
(II) RADEON(0): [drm] removed 1 reserved context for kernel
(II) RADEON(0): [drm] unmapping 8192 bytes of SAREA 0xf8684000 at 0xb7be9000
(II) RADEON(0): [drm] Closed DRM master.
Comment 1 Roger Luethi 2009-04-07 20:09:07 UTC
Created attachment 20865 [details]
X Server log
Comment 2 Rafael J. Wysocki 2009-04-26 11:50:19 UTC
Notify-Also : DRI <dri-devel@lists.sourceforge.net>
Comment 3 Rafael J. Wysocki 2009-04-27 20:20:15 UTC
On Monday 27 April 2009, Roger Luethi wrote:
> On Sun, 26 Apr 2009 11:46:29 +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.28 and 2.6.29.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=13040
> > Subject		: DRM radeon
> > Submitter	: Roger Luethi <rl@hellgate.ch>
> > Date		: 2009-04-07 20:07 (20 days old)
> 
> It is a regression, but it seems to have been introduced in 2.6.28, not
> 2.6.29.
> 2.6.27.20 works fine.
Comment 4 Florian Mickler 2010-09-02 07:38:55 UTC
Ping... Can this be closed, or is it still a problem?
Comment 5 Florian Mickler 2010-09-22 17:45:06 UTC
Timeout. 

Since radeon now uses kernel based mode setting this is unlikely to persist.

Note You need to log in before you can comment on or make changes to this bug.