Bug 13036 (sony_laptop) - ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320] ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
Summary: ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x008...
Status: CLOSED CODE_FIX
Alias: sony_laptop
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core (show other bugs)
Hardware: i386 Linux
: P1 high
Assignee: acpi_acpica-core@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-07 10:12 UTC by Giovanni Pellerano
Modified: 2009-04-28 15:58 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.29-git14
Tree: Mainline
Regression: Yes


Attachments
acpi dump sony vaio sr19xn (167.90 KB, application/octet-stream)
2009-04-07 21:21 UTC, Giovanni Pellerano
Details
patch vs 2.6.29-git14 (1.18 KB, patch)
2009-04-07 21:37 UTC, Len Brown
Details | Diff
acpidump vgn-fw235j (163.03 KB, application/octet-stream)
2009-04-08 00:32 UTC, Rodrigo L. Batista
Details
patch vs 2.6.30-rc1 (4.38 KB, patch)
2009-04-10 07:03 UTC, Lin Ming
Details | Diff
patch from comment #10, as applied to acpi tree (5.25 KB, patch)
2009-04-24 04:31 UTC, Len Brown
Details | Diff

Description Giovanni Pellerano 2009-04-07 10:12:18 UTC
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q58] (Node f701ab58), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q59] (Node f701ab70), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q58] (Node f701ab58), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q59] (Node f701ab70), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q25] (Node f701a348), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q25] (Node f701a348), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q25] (Node f701a348), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q25] (Node f701a348), AE_AML_ILLEGAL_ADDRESS
ACPI Error (hwvalid-0186): Denied AML access to port 0x00000080/4 (DMA1 0x0081-0x0083) [20090320]
ACPI Exception (evregion-0422): AE_AML_ILLEGAL_ADDRESS, Returned by Handler for [SystemIO] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\P8XH] (Node f7017900), AE_AML_ILLEGAL_ADDRESS
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._Q25] (Node f701a348), AE_AML_ILLEGAL_ADDRESS
Comment 1 Giovanni Pellerano 2009-04-07 21:10:08 UTC
i've forgot to say
Comment 2 Giovanni Pellerano 2009-04-07 21:11:54 UTC
I've forgot to say, i've a Sony Vaio SR 19XN;

i'm going to attach the acpi dump.
Comment 3 Giovanni Pellerano 2009-04-07 21:21:58 UTC
Created attachment 20866 [details]
acpi dump sony vaio sr19xn
Comment 4 Len Brown 2009-04-07 21:26:26 UTC
This Sony has lots of writes to debug port 0x80.
However, the AML is doing this with 32-bit writes 
rather than a 1-byte write.

Linux is detecting the illegal access to ports 81-83,
blocking them, and complaining.

My guess is that Windows would allow a 1-byte write
to port 80, but silently block a 4-byte write
to port 80.

The DSDT in this sony is full of debug writes
to method P8XH, so you'll get these whenever 
the BIOS developer wanted to write to the 7-segment
debug port on their prototype -- over 60 calls...
Comment 5 Giovanni Pellerano 2009-04-07 21:37:31 UTC
is there something i can do to help you?
Comment 6 Len Brown 2009-04-07 21:37:45 UTC
Created attachment 20867 [details]
patch vs 2.6.29-git14

Please verify that this patch makes the error messages go away.
Comment 7 Rodrigo L. Batista 2009-04-08 00:32:57 UTC
Created attachment 20872 [details]
acpidump vgn-fw235j
Comment 8 Rodrigo L. Batista 2009-04-08 01:14:06 UTC
This patch works. There is no more errors.
Comment 9 Giovanni Pellerano 2009-04-08 08:36:12 UTC
i think the patch works also on my sony vaio sr 19xn.

at the time i did not have that message any more.


instead i got:

ACPI: EC: missing confirmations, switch off interrupt mode.
ACPI Exception (evregion-0422): AE_TIME, Returned by Handler for [EmbeddedControl] [20090320]
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.ADP1._PSR] (Node f701aea0), AE_TIME
ACPI Exception (ac-0135): AE_TIME, Error reading AC Adapter state [20090320]


is this related?
Comment 10 Lin Ming 2009-04-10 07:03:52 UTC
Created attachment 20913 [details]
patch vs 2.6.30-rc1

On Thu, Apr 9, 2009 at 10:56 PM, Moore, Robert <robert.moore@intel.com> wrote:
> A 4-byte write to an I/O port means four one-byte writes to 
> four consecutive I/O ports (although, this can be done in one machine 
> instruction.)
>
> From our testing, Windows indeed is only allowing the single-byte write to
> the (legal) port 0x80. The rest of the request is simply ignored.
> In general, any part of an I/O request that overlaps the protected ports
> is ignored. No error is returned.
>
> We are updating ACPICA to match this behavior.
>
> Bob

As Bob said above, the attachment is the linux ACPICA patch.

Giovanni, would you please help to test this patch?
(only this patch, and do not apply the patch at comment #6)

Thanks.
Comment 11 Giovanni Pellerano 2009-04-10 08:31:05 UTC
Ok it does work Lin! =)

Well done!

thanks a lot.
Comment 12 Lin Ming 2009-04-10 17:55:36 UTC
Does the error message you got at comment #9 also disappear?

Thanks for testing.
Comment 13 Giovanni Pellerano 2009-04-10 20:56:50 UTC
No, i got them randomly. Should them heve been disappeared?
Comment 14 Lin Ming 2009-04-13 03:15:51 UTC
Did you got them before 2.6.30-rc1?
Comment 15 Giovanni Pellerano 2009-04-13 17:41:25 UTC
yes, i think that is not a regression but an old bug never solved

do you need someting ?
Comment 16 Lin Ming 2009-04-14 03:20:13 UTC
Would you please file a new bug report for that error message since it's not related to this report?
Comment 17 Giovanni Pellerano 2009-04-14 06:52:25 UTC
yes.

i've just done it: http://bugzilla.kernel.org/show_bug.cgi?id=13055
Comment 18 Len Brown 2009-04-24 04:31:54 UTC
Created attachment 21100 [details]
patch from comment #10, as applied to acpi tree
Comment 19 Len Brown 2009-04-24 04:37:09 UTC
patch in comment #6 reverted from acpi tree.
Comment 20 Len Brown 2009-04-28 15:58:18 UTC
patch from comment #18
and revert from comment #19
shipping in linux-2.6.30-rc3-git4

closed

Note You need to log in before you can comment on or make changes to this bug.