Bug 13027 - Resume after hibernation regression in forcedeth
Resume after hibernation regression in forcedeth
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-04-06 20:39 UTC by Rafael J. Wysocki
Modified: 2009-04-26 10:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments

Description Rafael J. Wysocki 2009-04-06 20:39:57 UTC
Subject    : Resume after hibernation regression in 2.6.29
Submitter  : "Tvrtko A. Ursulin" <tvrtko@ursulin.net>
Date       : 2009-03-27 20:09
References : http://marc.info/?l=linux-kernel&m=123818507814476&w=4
Handled-By : Ed Swierk <eswierk@aristanetworks.com>
Patch      : http://marc.info/?l=linux-kernel&m=123878076717061&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Per Wigren 2009-04-10 09:44:17 UTC
I just wanted to add a comment to this thread without having to subscribe to lkml. The problem I'm seeing is the one described, but it seems to bring the whole device down with it hard. Even a reboot doesn't restore the link and gPXE, Linux 2.6.29.1 or older versions (tested with a 2.6.27 version) can't find the link any more even after a power cycle restart. The only way I can find to bring it up again is to boot into windows (I just installed an old copy of XP to a spare partition just for this) and when the green light starts to flash again, I can reboot and netboot with gPXE or use the interface in Linux again.

The reason I'm commenting is that the patch seems to my context-less, untrained eye, to be restoring the link on resume/init, but that won't help those who are netbooting with gPXE, or rebooting into older versions of Linux.

This is on an MCP55 motherboard.
Comment 2 Rafael J. Wysocki 2009-04-26 10:55:47 UTC
Fixed by commit 35a7433c789ba6df6d96b70fa745ae9e6cac0038 .

Note You need to log in before you can comment on or make changes to this bug.