Bug 13017 - ATA bus errors on resume
ATA bus errors on resume
Status: CLOSED OBSOLETE
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-04-05 22:04 UTC by Rafael J. Wysocki
Modified: 2012-05-30 15:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: Yes


Attachments
EXT4 errors, captured with Tejun's debug patch (21.38 KB, text/plain)
2009-05-25 22:01 UTC, Niel Lambrechts
Details
No EXT4 errors, using Tejun's debug patch (33.65 KB, text/plain)
2009-05-25 22:02 UTC, Niel Lambrechts
Details
messages (2.6.29.4 - no EXT4 errors) (246.36 KB, text/plain)
2009-05-25 22:04 UTC, Niel Lambrechts
Details
messages (2.6.28.10 - no EXT4 errors) (42.85 KB, text/plain)
2009-05-25 22:04 UTC, Niel Lambrechts
Details

Description Rafael J. Wysocki 2009-04-05 22:04:25 UTC
Subject    : 2.6.29 regression: ATA bus errors on resume
Submitter  : Niel Lambrechts <niel.lambrechts@gmail.com>
Date       : 2009-03-25 5:19
References : http://marc.info/?l=linux-kernel&m=123795841615989&w=4
Handled-By : Tejun Heo <htejun@gmail.com>
Patch      : http://marc.info/?l=linux-kernel&m=123865517107421&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-04-06 21:09:29 UTC
Ignore-Patch : http://marc.info/?l=linux-kernel&m=123865517107421&w=4
Comment 2 Rafael J. Wysocki 2009-04-26 11:40:56 UTC
No reporter response, closing.
Comment 3 Niel Lambrechts 2009-05-25 21:47:09 UTC
EXT4 file-system errors resurfaced in 2.6.30-rc6. Was able to trigger the bug with Tejun Heo's debug patch. Problem under discussion.
Comment 4 Niel Lambrechts 2009-05-25 22:01:41 UTC
Created attachment 21548 [details]
EXT4 errors, captured with Tejun's debug patch
Comment 5 Niel Lambrechts 2009-05-25 22:02:57 UTC
Created attachment 21549 [details]
No EXT4 errors, using Tejun's debug patch
Comment 6 Niel Lambrechts 2009-05-25 22:04:17 UTC
Created attachment 21550 [details]
messages (2.6.29.4 - no EXT4 errors)
Comment 7 Niel Lambrechts 2009-05-25 22:04:58 UTC
Created attachment 21551 [details]
messages (2.6.28.10 - no EXT4 errors)
Comment 8 Niel Lambrechts 2009-05-25 22:14:40 UTC
Description of above /var/log/messages attachments:

I did a hibernation/resume cycle using console, then X for each kernel I have back to 2.6.28. I originally noticed EXT4 errors in 2.6.29 and now again in 2.6.30-rc6 (perhaps rc5 as well), but these still only happen intermittently.

I attached 2 x /var/log/messages output for 2.6.30-rc6. Both running Tejun's debug patch, but one of them has output when the EXT4 file-system errors triggered.

The other older kernel version messages I attached for the sake of comparison. They also seem to contain ATA resets.

Niel
Comment 9 Niel Lambrechts 2009-05-30 08:30:03 UTC
Tested Tejun's readahead patch, which did not trigger the bug.

Bug seen again in latest 2.6.30-rc7 git kernel, with a resume after hibernating leading to EXT4 errors.

Also, it seems 2.6.28.10 is good, I took some time to try and trigger it there, but it did not even when hibernating with a reasonably active system.

I am going to try and bisect this again, it is driving me up the wall.

Regards,
Niel
Comment 10 Florian Mickler 2010-11-11 19:43:34 UTC
Is this bug still present in current mainline kernels?

Note You need to log in before you can comment on or make changes to this bug.