Bug 12981 - Message after suspend: "BUG cred_jar (Not tainted): Poison overwritten"
Message after suspend: "BUG cred_jar (Not tainted): Poison overwritten"
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-03-31 10:19 UTC by Clemens Eisserer
Modified: 2011-03-03 01:28 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments

Description Clemens Eisserer 2009-03-31 10:19:44 UTC
This happend the after weaking up from suspend to disk with 2.6.29-16.fc11.i586, after a few minutes of work I got an oops (http://www.kerneloops.org/submitresult.php?number=318177)

=============================================================================                      
BUG cred_jar (Not tainted): Poison overwritten                                                     
-----------------------------------------------------------------------------                      

INFO: 0xf66bec00-0xf66bec1f. First byte 0x0 instead of 0x6b
INFO: Allocated in prepare_creds+0x31/0x9b age=22708 cpu=1 pid=17059
INFO: Freed in put_cred_rcu+0x69/0x70 age=22681 cpu=0 pid=0         
INFO: Slab 0xc1f94488 objects=21 used=16 fp=0xf66bec00 flags=0x400000c3
INFO: Object 0xf66bec00 @offset=3072 fp=0xf66be600                     

Bytes b4 0xf66bebf0:  5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a ZZZZZZZZZZZZZZZZ
  Object 0xf66bec00:  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
  Object 0xf66bec10:  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
  Object 0xf66bec20:  6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b kkkkkkkkkkkkkkkk
  Object 0xf66bec30:  6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b kkkkkkkkkkkkkkkk
  Object 0xf66bec40:  6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b kkkkkkkkkkkkkkkk
  Object 0xf66bec50:  6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b kkkkkkkkkkkkkkkk
  Object 0xf66bec60:  6b 6b 6b 6b 6b 6b 6b 6b 6b 6b 6b a5             kkkkkkkkkkk�    
 Redzone 0xf66bec6c:  bb bb bb bb                                     ����            
 Padding 0xf66bec94:  5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a ZZZZZZZZZZZZZZZZ
 Padding 0xf66beca4:  5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a ZZZZZZZZZZZZZZZZ
 Padding 0xf66becb4:  5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a 5a             ZZZZZZZZZZZZ    
Pid: 2742, comm: plasma Not tainted 2.6.29-16.fc11.i586 #1                            
Call Trace:                                                                           
 [<c04a357e>] print_trailer+0xe5/0xed                                                 
 [<c04a3890>] check_bytes_and_report+0x91/0xb4                                        
 [<c04a3992>] check_object+0xaa/0x164                                                 
 [<c04a4809>] __slab_alloc+0x325/0x41a                                                
 [<c04a4bb9>] kmem_cache_alloc+0x8c/0x100                                             
 [<c044735c>] ? prepare_creds+0x31/0x9b                                               
 [<c044735c>] ? prepare_creds+0x31/0x9b                                               
 [<c044735c>] prepare_creds+0x31/0x9b                                                 
 [<c04a9a3b>] sys_faccessat+0x33/0x16e                                                
 [<c04a9b8b>] sys_access+0x15/0x17                                                    
 [<c0403f92>] syscall_call+0x7/0xb                                                    
FIX cred_jar: Restoring 0xf66bec00-0xf66bec1f=0x6b                                    

FIX cred_jar: Marking all objects used
Comment 1 Rafael J. Wysocki 2009-03-31 13:06:28 UTC
It looks like memory corruption, but I have no idea what might cause it to happen.

How reproducible is this?
Comment 2 Clemens Eisserer 2009-04-27 12:49:52 UTC
Haven't seen it for some time now - quite likely its already fixed.
I also experienced a lot of problems with Intel's GEM when I saw that problem, so maybe there is/was a releation.
Comment 3 Zhang Rui 2009-06-23 08:09:24 UTC
Clemens, does the problem still exist?
please re-open this bug if it's still reproducible in the latest upstream kernel.

Note You need to log in before you can comment on or make changes to this bug.