Bug 12952 - Key brightness events repeat forever
Summary: Key brightness events repeat forever
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Dmitry Torokhov
URL: http://bugs.freedesktop.org/show_bug....
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-27 10:21 UTC by Sam Morris
Modified: 2009-05-04 18:37 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
dmidecode output (8.89 KB, text/plain)
2009-04-12 12:00 UTC, Sam Morris
Details

Description Sam Morris 2009-03-27 10:21:39 UTC
I have a Samsung Q45 laptop. Pressing the brightness up/down keys causes the kernel to emit a key down event; subsequent presses emit a key repeat event. No key up event is ever emitted.

I originally filed this as a bug in Xorg but was told it was a kernel problem. You can find the output of 'evtest' for the key at <http://bugs.freedesktop.org/show_bug.cgi?id=20862>.

User impact: pressing the brightness up/down keys causes gnome-power-manager to grab the keyboard, and since the keys are never released (at least according to the X server), it becomes impossible to use the keyboard or open any menus until I perform magic (log in via other means and kill gnome-power-manager). Original bug filed at <http://bugzilla.gnome.org/show_bug.cgi?id=576283>.
Comment 1 Dmitry Torokhov 2009-04-12 02:56:55 UTC
Could I please have output of 'dmidecode' on your box? Thanks!
Comment 2 Sam Morris 2009-04-12 12:00:48 UTC
Created attachment 20943 [details]
dmidecode output
Comment 3 Sam Morris 2009-04-23 11:09:10 UTC
Is there a way for me to flick the status back to UNCONFIRMED or similar? GNOME's bugzilla allows end-users to do this but I'm not sure how to do it here...
Comment 4 Dmitry Torokhov 2009-04-27 21:29:22 UTC
Any chance you could try 2.6.30-rc3?
Comment 5 Sam Morris 2009-05-01 13:30:39 UTC
This appears to be fixed with 2.6.30-rc4. Thanks!

Note You need to log in before you can comment on or make changes to this bug.