Bug 12950 - [i915] allocate MCHBAR space & enable if necessary
[i915] allocate MCHBAR space & enable if necessary
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-03-27 02:03 UTC by Eric Appleman
Modified: 2010-09-03 08:54 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments
allocate MCHBAR space & enable if necessary (7.58 KB, patch)
2009-03-27 02:04 UTC, Eric Appleman
Details | Diff

Description Eric Appleman 2009-03-27 02:03:06 UTC
Fixes tiling issues and slowdown on i915 chipsets.
Comment 1 Eric Appleman 2009-03-27 02:04:03 UTC
Created attachment 20698 [details]
allocate MCHBAR space & enable if necessary
Comment 2 Eric Appleman 2009-03-27 02:11:59 UTC
Read this thread for more info:
http://lists.freedesktop.org/archives/intel-gfx/2009-January/001187.html
Comment 3 Fabio Comolli 2009-03-31 10:36:53 UTC
IMHO this bug should be list as a regression from 2.7.27.X 

My test case is a program called stellarium (www.stellarium.org). With 2.6.27.X I get about 15/20 fps and the software in perfectly usable. With 2.6.29 performance drops down to less than 3 fps.

The patch doesn't help for me; I mean the error is gone but the performance remains exactly the same.

The system is an eeePC 900, more details on request.
Comment 4 Rafael J. Wysocki 2009-03-31 13:02:41 UTC
Made it block bug #11808 on the basis of comment #3.
Comment 5 Fabio Comolli 2009-03-31 14:10:13 UTC
FWIW, replacing the drivers/gpu/drm and the include/linux/drm with the ones from 2.6.27.X and fixing a trivial (I hope!) compilation problem, I got 20fps with 2.6.29 .

This was, obviously, without userspace changes.
Comment 6 Martin Pitt 2009-04-08 16:48:19 UTC
For the record, this patch causes a regression at least on the i945GM, it freezes a few minutes after suspend. See https://bugs.freedesktop.org/show_bug.cgi?id=20520 for details.
Comment 7 Fabio Comolli 2009-04-09 21:53:36 UTC
Performance regression still present in 2.6.30-rc1
Comment 8 Fabio Comolli 2009-04-27 20:06:08 UTC
OK, it seems there's no activity on this one.

Anyway, I managed to "solve" it by upgrading my distro's X.org from 1.5.2 to 1.6.1, which comes with intel driver v. 2.7.0 .

This, combined with the i915 patch attached to this bug, even gives some performance improvement compared to 2.6.27.x with X.org v1.5.2 .

This is true for both kernel 2.6.29.1 and 2.6.30-rc3 (modulo that on this one the patch does not apply cleanly but needs a modification in a comment line).

By the way, my distro is OpenSuse 11.1, so not really an obsolete one. The new userspace is from the official X.org repository.

Maybe the kernel devs should have stated more clearly that if you want to run 3D apps with Intel chipset a new X.org is needed.

One last detail: 2.6.30-rc3 without the MCHBAR patch crashes running glxgears (powercycle needed). Another _BAD_ regression, at least compared to 2.6.27.x (didn't try 2.6.29.1 without the patch).
Comment 9 Florian Mickler 2010-08-27 15:53:10 UTC
hi!

i've added some intel gfx cc's (i hope the right ones)...

do you still need to patch the kernel to avoid a crash? if so, do you have some backtraces?
Comment 10 Florian Mickler 2010-09-03 08:16:17 UTC
ping...
Comment 11 Fabio Comolli 2010-09-03 08:46:51 UTC
Well, since then (more than one year), I changed distibution, three xorg versions and 7 kernel versions.

This patch is not necessary anymore.
Comment 12 Florian Mickler 2010-09-03 08:54:33 UTC
Good to hear. 

Cheers,
Flo

Note You need to log in before you can comment on or make changes to this bug.