Bug 12935 - Suspend to ram on Intel X3100 fails to resume with compositing enabled
Suspend to ram on Intel X3100 fails to resume with compositing enabled
Status: RESOLVED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 10:04 UTC by Joost
Modified: 2009-09-17 03:50 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29.0
Tree: Mainline
Regression: Yes


Attachments
lspci (1.98 KB, text/plain)
2009-03-25 10:05 UTC, Joost
Details

Description Joost 2009-03-25 10:04:41 UTC
Hello everybody,

thanks to everyone for your efforts with all this stuff!

I just upgraded to 2.6.29.0 from 2.6.28.7. Now to make this shorter:

-I have used 2.6.28.7 for months to suspend to ram with kde 4.2 and compositing enabled without a single crash I remember, often 5-10 times a day

-On updating to 2.6.29.0:

      -suspend to ram from text-mode/console (no x running) works seemingly always (tried ten times, rebooted, tried again, always succes). Command used was 'echo "mem" > /sys/power/state"
      
      -suspend to ram from x WITHOUT compositing works seemingly always, see above, same testing procedure

      -suspending with compositing enabled crashed all six times I tried (also with pm-suspend). On resuming, the backlight comes on again, the mouse is stuck, no ctrl-alt-f1/backspace works, sometimes there are garbled remainings from my wallpaper, but mostly it's black with only the unmovable mouse cursor showing 

Hardware is a macbook 3,1, see attached lspci.

Thanks for any help in fixing this regression!

Joost
Comment 1 Joost 2009-03-25 10:05:15 UTC
Created attachment 20667 [details]
lspci
Comment 2 Gordon Jin 2009-09-17 03:50:21 UTC
If 2.6.31 still has this problem, please file a bug to freedesktop according to http://www.intellinuxgraphics.org/how_to_report_bug.html. Thanks.

Note You need to log in before you can comment on or make changes to this bug.