Bug 12930 - Very low signal strenghts with ath9k in 2.6.29
Summary: Very low signal strenghts with ath9k in 2.6.29
Status: RESOLVED DUPLICATE of bug 13537
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Senthil Balasubramanian
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-24 10:14 UTC by drago01
Modified: 2009-07-01 16:00 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
iwlist scan output using 2.6.29 (3.99 KB, text/plain)
2009-03-24 10:15 UTC, drago01
Details
iwlist scan output using 2.6.29-rc8-wl (3.99 KB, text/plain)
2009-03-24 10:15 UTC, drago01
Details
debug output (16.21 KB, text/plain)
2009-04-10 08:44 UTC, drago01
Details
patch to solve the signal quality issue (3.70 KB, patch)
2009-05-20 10:14 UTC, Senthil Balasubramanian
Details | Diff
scan result with this patch (1.97 KB, text/plain)
2009-05-20 11:06 UTC, drago01
Details
output of iwlist scan using the intel iwl3945 card (3.42 KB, text/plain)
2009-05-20 12:43 UTC, drago01
Details
scan result with rt2500usb on the same machine (7.73 KB, text/plain)
2009-05-22 16:48 UTC, drago01
Details

Description drago01 2009-03-24 10:14:30 UTC
I have a Dlink DWA-547 PCI Card which is supported by the ath9k driver.

With the version in 2.6.29 I get very low signal strengths reported. (Usally between 4% and 6%).

My laptop using the iwl3945 driver reports much better signal strengths with the same distance to the AP.

I tested with -wl and got better results but they where still not that good.

Also -wl reports the signals as xx/70 while 2.6.29 reports xx/100 .

Will attach both iwlist scan outputs.
Comment 1 drago01 2009-03-24 10:15:18 UTC
Created attachment 20659 [details]
iwlist scan output using 2.6.29
Comment 2 drago01 2009-03-24 10:15:46 UTC
Created attachment 20660 [details]
iwlist scan output using 2.6.29-rc8-wl
Comment 3 drago01 2009-03-24 10:16:47 UTC
phy0: Atheros AR5416 MAC/BB Rev:2 AR2133 RF Rev:81: mem=0xffffc200118e0000, irq=
17
Comment 4 Luis Chamberlain 2009-03-24 12:47:37 UTC
Thank you very much for the report. Next step is to determine if this is a regression or not. To find we'll need to see if this is present on 2.6.27 or 2.6.28. Please let us know if you get to test this, regardless it will be addressed first on wireless-testing.
Comment 5 drago01 2009-03-28 19:40:09 UTC
(In reply to comment #4)
> Thank you very much for the report. Next step is to determine if this is a
> regression or not. To find we'll need to see if this is present on 2.6.27 or
> 2.6.28. Please let us know if you get to test this, regardless it will be
> addressed first on wireless-testing.

Sorry for the delay it seems to happen with 2.6.27 too (have not tested 2.6.28), but 2.6.29 + compat-wireless-2009-03-28 seems to be ok (39/70) -> same levels as the iwl3945 card.

----
wlan0     Scan completed :
          Cell 01 - Address: 00:1C:10:2F:A1:E7
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=39/70  Signal level=-71 dBm  
                    Encryption key:on
                    ESSID:"wrt54gl"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000a1433c9987
                    Extra: Last beacon: 20ms ago
                    IE: Unknown: 00077772743534676C
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010A
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD06001018020004
          Cell 02 - Address: 00:1C:DF:D4:E9:74
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=34/70  Signal level=-76 dBm  
                    Encryption key:on
                    ESSID:"BelkinS"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000008b308e6495
                    Extra: Last beacon: 879ms ago
                    IE: Unknown: 000742656C6B696E53
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1AEE110FFFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: 3D1601050700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4304000000
                    IE: Unknown: DD1E00904C33EE110FFFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: DD1A00904C3401050700000000000000000000000000000000000000
                    IE: Unknown: DD9F0050F204104A0001101044000102103B000103104700102880288028801880A880001CDFD4E9741021001242656C6B696E20436F72706F726174696F6E1023001642656C6B696E20576972656C65737320526F75746572102400034635441042000C3131313131313131313131311054000800060050F20400011011001642656C6B696E20576972656C65737320526F75746572100800020084103C000101
----
Comment 6 drago01 2009-03-28 19:57:01 UTC
The throughput seems odd thought.

I get around 2MB/s download speed using the test on speedtest.net, and 1.5MB/s upload.

Same test with the wired connection results into 9.6MB/s download and 0.86MB/s upload.

With iwl3945 (same range to the AP) I get 7.66MB/s download and 0.93MB/s upload.

So whats wrong with the download speed? Upload is near the maximum my ISP provides.

Testing with iperf I get 1.85MB/s (between ath9k desktop card and iwl3945 in the laptop).


iconfig shows "Bit Rate=12 Mb/s" while on the Intel card it says reports 24MB/s.
Comment 7 drago01 2009-03-28 20:01:07 UTC
There are some messages like:
-----
wlan0: beacon loss from AP 00:1c:10:2f:a1:e7 - sending probe request
wlan0: beacon loss from AP 00:1c:10:2f:a1:e7 - sending probe request
wlan0: beacon loss from AP 00:1c:10:2f:a1:e7 - sending probe request
wlan0: beacon loss from AP 00:1c:10:2f:a1:e7 - sending probe request
----

In dmesg
Comment 8 Sujith 2009-04-10 06:59:53 UTC
Can you update to the latest compat-wireless, and load the driver with the modparam 'debug=0x200', proceed to associate with your AP and then post the kernel log here ? Thanks.
Comment 9 drago01 2009-04-10 08:44:53 UTC
Created attachment 20915 [details]
debug output
Comment 10 drago01 2009-04-23 16:32:32 UTC
Todays compat-wireless is even worse, it cannot connect to the ap at all:
---
eth0: no IPv6 routers present
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 1
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 2
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 3
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 timed out
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 1
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 1
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 1
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 2
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 3
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 timed out
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 1
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 2
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 try 3
wlan0: direct probe to AP 00:1c:10:2f:a1:e7 timed out
----------

iwlist scan

----------
wlan0     Scan completed :
          Cell 01 - Address: 00:1C:10:2F:A1:E7
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=26/70  Signal level=-84 dBm  
                    Encryption key:on
                    ESSID:"wrt54gl"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000249798b186
                    Extra: Last beacon: 3947ms ago
                    IE: Unknown: 00077772743534676C
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010A
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD06001018020204
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
------------
Comment 11 Senthil Balasubramanian 2009-05-20 10:12:11 UTC
Please try the attached patch for the low signal issue and see if it helps. The patch can be applied on tip of wireless testing

Author: Reinette Chatre <reinette.chatre@intel.com>
Date:   Fri May 15 16:13:46 2009 -0700

    iwlwifi: do not cancel delayed work inside spin_lock_irqsave
    
    Calling cancel_delayed_work() from inside
    spin_lock_irqsave, introduces a potential deadlock.
    
    As explained by Johannes Berg <johannes@sipsolutions.net>
Comment 12 Senthil Balasubramanian 2009-05-20 10:14:53 UTC
Created attachment 21445 [details]
patch to solve the signal quality issue

This patch should be applied on top of the following commit.

Author: Reinette Chatre <reinette.chatre@intel.com>
Date:   Fri May 15 16:13:46 2009 -0700

    iwlwifi: do not cancel delayed work inside spin_lock_irqsave
    
    Calling cancel_delayed_work() from inside
    spin_lock_irqsave, introduces a potential deadlock.
    
    As explained by Johannes Berg <johannes@sipsolutions.net>
Comment 13 drago01 2009-05-20 11:06:36 UTC
Created attachment 21446 [details]
scan result with this patch

I have tried the patch, but unfortunately it does not seem to change anything. (ie. signal strengths still low)

Btw. the timeout problem I reported in #10 is solved (was only related to the specific snapshot I tested with earlier).
Comment 14 Senthil Balasubramanian 2009-05-20 11:29:32 UTC
Can you please attach the iwlist scan output with Intel Card.?
Comment 15 drago01 2009-05-20 12:43:13 UTC
Created attachment 21447 [details]
output of iwlist scan using the intel iwl3945 card

Sure output attached. (Same range to the AP)
Comment 16 vasanthakumar 2009-05-20 13:39:39 UTC
What about the signal strength of the associated AP with the above patch?.
Comment 17 drago01 2009-05-20 13:47:58 UTC
(In reply to comment #16)
> What about the signal strength of the associated AP with the above patch?.

25/70 see:

--------------
wlan0     Scan completed :
          Cell 01 - Address: 00:1C:10:2F:A1:E7
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=25/70  Signal level=-85 dBm  
                    Encryption key:on
                    ESSID:"wrt54gl"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000007aca85984
                    Extra: Last beacon: 7119ms ago
                    IE: Unknown: 00077772743534676C
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD06001018020004
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
---------------
Comment 18 drago01 2009-05-22 16:48:47 UTC
Created attachment 21493 [details]
scan result with rt2500usb on the same machine

The attched output contains the scan result (iwlist scan) with an rt2500usb based device plugged in.

As you can see the Atheros card (wlan0) reports much weaker signal strengths as the ralink one (wlan1).
Comment 19 drago01 2009-05-23 11:38:08 UTC
Btw. it seems that the Atheros Device has the exact same issues in Windows Vista x64.
Comment 20 Luis Chamberlain 2009-06-22 15:42:17 UTC
drago01, please check out the patches at:

http://bugzilla.kernel.org/show_bug.cgi?id=13537

John, can this bug be marked duplicate of 13537?

Thanks!
Comment 21 John W. Linville 2009-07-01 16:00:13 UTC

*** This bug has been marked as a duplicate of bug 13537 ***

Note You need to log in before you can comment on or make changes to this bug.