Bug 12918 - wistron_btns does not support RFKILL switch on P157 (aka aopen 1557 aka MS2141)
wistron_btns does not support RFKILL switch on P157 (aka aopen 1557 aka MS2141)
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 enhancement
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 04:20 UTC by Tomáš Hnyk
Modified: 2009-08-24 11:05 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29-rc8
Tree: Mainline
Regression: No


Attachments
wistron_btns: Implement RF-Kill support for some Acer and no-name systems (1.16 KB, patch)
2009-07-30 07:41 UTC, TJ
Details | Diff

Description Tomáš Hnyk 2009-03-22 04:20:28 UTC
Latest working kernel version: none
Earliest failing kernel version: all
Distribution: Ubuntu 8.10 Intrepid Ibex
Hardware Environment: Prestigio 157
Software Environment: 
Problem Description: Prestigio 157 is hardwarewise the same as aopen 1557 or MS2141 that are supported by wistron_btns. (It only lacks the audio panel so that there are less buttons to be supported, but those that are on the notebook are the same as for 1557 and MS2141.) However, when I press the button that is supposed to turn on/off the wifi, nothing happens. I do not know hether this affects also aopen and MS models or whether it is specific only to my model, but since they are the same it should not be. This is especially unfortunate since when resuming from sleep, wifi is not turned on and there is no way to turn it on.

There is unmaintained out of the tree driver called acerhk that makes it possible to turn the wifi on and off but with it, wifi also does not work after resuming from sleep. Only with acerhk, it is possible to turn it on manually with the button.

I will gladly provide any additional info you might need. I have subscribed the three people that are listed as authors of the driver.
Comment 1 TJ 2009-07-30 07:40:35 UTC
Attaching patch I committed to Ubuntu in March 2009 and have submitted to LKML after declared maintainer of module did not respond.
Comment 2 TJ 2009-07-30 07:41:32 UTC
Created attachment 22529 [details]
wistron_btns: Implement RF-Kill support for some Acer and no-name systems
Comment 3 Tomáš Hnyk 2009-08-24 11:05:56 UTC
It has been accepted into kernel (http://lkml.org/lkml/2009/8/13/549), so I guess this is RESOLVED.

Note You need to log in before you can comment on or make changes to this bug.