Bug 12910 - ACPI limits CPU to 800Mhz
ACPI limits CPU to 800Mhz
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Power-Thermal
All Linux
: P1 normal
Assigned To: Len Brown
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-03-21 11:13 UTC by Rafael J. Wysocki
Modified: 2009-04-01 00:45 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-21 11:13:25 UTC
Subject    : 2.6.29-rcX: wierd iteractions with CPUFREQ
Submitter  : Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date       : 2009-03-19 5:57
References : http://marc.info/?l=linux-kernel&m=123744265002098&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alan 2009-03-21 12:44:09 UTC
Can you confirm going back to older kernels goes back to the old behaviour ? If so which rc did it break ?
Comment 2 ykzhao 2009-03-22 07:01:04 UTC
Hi, Dmitry
    Will you please attach the output of acpidump, dmesg?
    It will be great if you can verify what Alan said in comment #1.
    Thanks.
Comment 3 Zhang Rui 2009-03-23 00:58:18 UTC
please verify if this is a duplicate of bug #12830
Comment 4 Zhang Rui 2009-03-23 01:01:13 UTC
sorry, it's not.
on this laptop, the problem is that no ACPI events when overheating, which results in a low cpu frequency.
Comment 5 Len Brown 2009-03-23 18:45:34 UTC
> acpi_processor_ppc_has_changed

this is the BIOS instructing us to run slower,
so AFAICS we are doing the right thing.

We've seen several machines with BIOS that use PPC update
to manage thermals, eg the T60.  What box is this, and
where is its acpidump?  Did it not heat up in previous releases?
Is the fan spinning at full speed when this happens?
(has it recently become clogged?)
Comment 6 Zhang Rui 2009-03-30 05:50:43 UTC
ping Dmitry.
Comment 7 Dmitry Torokhov 2009-03-30 09:04:32 UTC
Ignore me, please. It was indeed _PPC silently limiting the frequency, apparently because nvidia chip is overheating. Nothing to do with 2.6.29 except that I was trying to go off binary module and back to free nv driver at the same time and apparently nv keeps the chip at max performance at all times.

Note You need to log in before you can comment on or make changes to this bug.