Bug 12894 - Terratec CinergyT² can only lock with option frontend_debug=1 for dvb_core
Terratec CinergyT² can only lock with option frontend_debug=1 for dvb_core
Status: CLOSED CODE_FIX
Product: v4l-dvb
Classification: Unclassified
Component: dvb-core
All Linux
: P1 high
Assigned To: dvb-core
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-03-19 13:36 UTC by Johannes Engel
Modified: 2010-09-06 07:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.28.7
Tree: Mainline
Regression: Yes


Attachments

Description Johannes Engel 2009-03-19 13:36:49 UTC
Latest working kernel version: 2.6.27
Earliest failing kernel version: 2.6.28
Distribution: openSUSE 11.1
Hardware Environment: i686, Terratec CinergyT²
Software Environment: tzap
Problem Description: tzap can only lock to a channel if dvb_core is loaded with option frontend_debug=1
Without that option it gives

tzap -c .mplayer/channels.conf -r ZDF
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
reading channels from file '.mplayer/channels.conf'
tuning to 778000000 Hz
video pid 0x0221, audio pid 0x0222
status 01 | signal 2223 | snr 0000 | ber 00000000 | unc 00000000 |
status 07 | signal 0220 | snr 5c5c | ber 00000000 | unc 00000000 |
status 05 | signal 911f | snr 0000 | ber 00000000 | unc 00000000 |

With frontend_debug=1 it gives

tzap -c .mplayer/channels.conf -r ZDF
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
reading channels from file '.mplayer/channels.conf'
tuning to 778000000 Hz
video pid 0x0221, audio pid 0x0222
status 01 | signal b11b | snr 0000 | ber 00000000 | unc 00000000 | 
status 1f | signal 411f | snr 8080 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal 2220 | snr 8282 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
Comment 1 Florian Mickler 2010-09-03 09:15:25 UTC
Hi!

Does this ancient issue still exist in current kernels?
Comment 2 Johannes Engel 2010-09-03 22:23:33 UTC
Haven't seen this for a long time, this implies that at least since 2.6.33 this is gone.

Note You need to log in before you can comment on or make changes to this bug.