Bug 12872 - pwc mmap always fails with EAGAIN
pwc mmap always fails with EAGAIN
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-03-14 12:02 UTC by Rafael J. Wysocki
Modified: 2009-04-26 11:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-14 12:02:41 UTC
Subject    : REGRESSION: 2.6.28.7 => 2.6.29-rc8: pwc mmap always failes with EAGAIN
Submitter  : Markus <M4rkusXXL@web.de>
Date       : 2009-03-14 16:42
References : http://marc.info/?l=linux-kernel&m=123704902201378&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Fryderyk Dziarmagowski 2009-03-25 09:32:00 UTC
I can confirm it. I got a Philips SPC 900NC USB webcam working with 2.6.28.x but it fails with 2.6.29 (causes popular propertiary video conferencig software to crash)
Same failure as Markus described:
(from gstreamer-properties)
Could not map buffers from device '/dev/video0'
Failed to create buffer pool: Resource temporarily unavailable]
dmesg doesn't provide any information, just standard pwc output:

pwc: Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
pwc: Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
pwc: the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and VCS-UM100.
pwc: Philips SPC 900NC USB webcam detected.
pwc: Registered as /dev/video0.
usbcore: registered new interface driver Philips webcam

my setup:
linux 2.6.29 SMP preempt mod_unload CORE2 4KSTACKS
I can provide more detailed info, just ask me.
Comment 2 Fryderyk Dziarmagowski 2009-03-27 17:09:18 UTC
applying patches:
http://marc.info/?l=linux-kernel&m=123691716419111&w=2
and
http://marc.info/?l=dri-devel&m=123606627824556&w=2

solves the problem.
Comment 3 Alex Villacis Lasso 2009-03-31 23:32:05 UTC
Looks like bug 12920 and this bug are duplicates of each other.
Comment 4 Suresh B Siddha 2009-04-04 00:24:45 UTC
Fix for this issue (http://marc.info/?l=linux-kernel&m=123854290308079&w=2) went into linux-2.6.29.1. Can we please check 2.6.29.1 and close this bug if the issue is resolved?

Note You need to log in before you can comment on or make changes to this bug.