Bug 12871 - usb bluetooth crashes system
usb bluetooth crashes system
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Bluetooth
All Linux
: P1 normal
Assigned To: drivers_bluetooth@kernel-bugs.osdl.org
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-03-14 11:58 UTC by Rafael J. Wysocki
Modified: 2009-04-26 11:18 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-14 11:58:30 UTC
Subject    : 2.6.29-rc5+: usb bluetooth crashes system
Submitter  : Pavel Machek <pavel@ucw.cz>
Date       : 2009-03-10 11:23
References : http://marc.info/?l=linux-kernel&m=123668450400940&w=4
Notify-Also : Greg KH <greg@kroah.com>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Pavel Machek 2009-03-16 04:26:40 UTC
Ok, more info:

It works ok in 2.6.28.

It is repeatable by both ^c-ing the pppd or pressing red key on telephone to terminate the connection. Machine dies a brief moment after disconnect; "connection terminated" still gets to the log.

It happened many times in X; sometimes I see keyboard LEDs panic blink, sometimes not.

When repeated on the console, I get

BUG: spinlock bad magic on CPU#0, swapper/0

(and hard hang).

Comment 2 Rafael J. Wysocki 2009-04-07 21:17:38 UTC
References : http://lkml.org/lkml/2009/4/7/103

Note You need to log in before you can comment on or make changes to this bug.