Bug 12868 - iproute2 and regressing "ipv6: convert tunnels to net_device_ops"
iproute2 and regressing "ipv6: convert tunnels to net_device_ops"
Status: RESOLVED CODE_FIX
Product: Networking
Classification: Unclassified
Component: IPV6
All Linux
: P1 normal
Assigned To: Alexey Dobriyan
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-03-14 11:33 UTC by Rafael J. Wysocki
Modified: 2009-11-15 23:15 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-14 11:33:17 UTC
Subject    : iproute2 and regressing "ipv6: convert tunnels to net_device_ops"
Submitter  : Jan Engelhardt <jengelh@medozas.de>
Date       : 2009-03-09 14:46
References : http://marc.info/?l=linux-netdev&m=123660999632730&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit 1326c3d5a4b792a2b15877feb7fb691f8945d203
Author: Stephen Hemminger <shemminger@vyatta.com>
Date:   Thu Nov 20 20:33:56 2008 -0800

    ipv6: convert tunnels to net_device_ops

    Like IPV4, convert the tunnel virtual devices to use net_device_ops.

First-Bad-Commit : 1326c3d5a4b792a2b15877feb7fb691f8945d203

Notify-Also : netdev <netdev@vger.kernel.org>
Comment 1 Rafael J. Wysocki 2009-03-23 15:23:12 UTC
On Saturday 21 March 2009, Bjørn Mork wrote:
> 
> "Rafael J. Wysocki" <rjw-KKrjLPT3xs0@public.gmane.org> writes:
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.27 and 2.6.28.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.27 and 2.6.28.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12868
> > Subject		: iproute2 and regressing "ipv6: convert tunnels to net_device_ops"
> > Submitter	: Jan Engelhardt <jengelh-nopoi9nDyk+ELgA04lAiVw@public.gmane.org>
> > Date		: 2009-03-09 14:46 (13 days old)
> 
> This is fixed by commit 1b1d8f73a44fe1796a73a97ebcb08cad18b97f07
> currently in davem's net-2.6 tree.

Comment 2 Alexey Dobriyan 2009-11-15 23:15:41 UTC
commit 1b1d8f73a44fe1796a73a97ebcb08cad18b97f07
"ipv6: fix display of local and remote sit endpoints"

Note You need to log in before you can comment on or make changes to this bug.