Bug 12859 - Special keys unusable after resume on battery - T21
Summary: Special keys unusable after resume on battery - T21
Status: CLOSED DUPLICATE of bug 10932
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-sleep-wake
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-12 01:12 UTC by Karol Lewandowski
Modified: 2009-03-15 19:36 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc7
Tree: Mainline
Regression: ---


Attachments

Description Karol Lewandowski 2009-03-12 01:12:43 UTC
Latest working kernel version:
unknown or none

Earliest failing kernel version:
Earliest _tested_ by me failing kernel was 2.6.25

Distribution:
Debian 4.0, 5.0

Hardware Environment:
IBM Thinkpad T21

Problem Description:
IBM's special keys (Fn-X[*]) doesn't work after resume iff laptop is resumed on battery, without AC power connected. 

[*] X can be
F4 - suspend to ram,
F7 - change video output (lcd, lcd+crt, crt),
F12 - suspend to disk.

This bug is special case of http://bugzilla.kernel.org/show_bug.cgi?id=11674

In this case special keys do work if suspend and resume is on AC power (without disconnecting AC in between).

Steps to reproduce:
1. Boot laptop on AC power
2. Suspend
3. Disconnect AC power
4. Resume
Comment 1 Karol Lewandowski 2009-03-12 02:31:11 UTC
I've just found that bug was already reported, it's not fixed yet -- bug confirmed in 2.6.29-rc7.

*** This bug has been marked as a duplicate of bug 10932 ***

Note You need to log in before you can comment on or make changes to this bug.