Bug 12835 - Regression in backlight detection
Summary: Regression in backlight detection
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-video
URL:
Keywords:
Depends on:
Blocks: 11808
  Show dependency tree
 
Reported: 2009-03-07 12:58 UTC by Rafael J. Wysocki
Modified: 2009-03-17 10:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-07 12:58:18 UTC
Subject    : acer-wmi: fix regression in backlight detection
Submitter  : Michael Spang <mspang@csclub.uwaterloo.ca>
Date       : 2009-02-24 5:41
References : http://marc.info/?l=linux-kernel&m=123545411502396&w=4
Handled-By : Michael Spang <mspang@csclub.uwaterloo.ca>
Patch      : http://marc.info/?l=linux-kernel&m=123545411502396&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit febf2d95a71cd594182e4b3defb0e0ffdfe61482
Author: Thomas Renninger <trenn@suse.de>
Date:   Fri Aug 1 17:37:56 2008 +0200

    Acer-WMI: fingers off backlight if video.ko is serving this functionality

    Signed-off-by: Thomas Renninger <trenn@suse.de>
    Acked-by: Zhang Rui <rui.zhang@intel.com>
    Signed-off-by: Andi Kleen <ak@linux.intel.com>
    Acked-by: Carlos Corbacho <carlos@strangeworlds.co.uk>
    Signed-off-by: Len Brown <len.brown@intel.com>
Comment 1 Rafael J. Wysocki 2009-03-07 12:58:55 UTC
This is a regression from 2.6.28, sorry.
Comment 2 Rafael J. Wysocki 2009-03-07 12:59:22 UTC
This is a regression from 2.6.27, sorry again.
Comment 3 Zhang Rui 2009-03-08 19:56:01 UTC
Patch already available.
Comment 4 Len Brown 2009-03-17 10:06:38 UTC
1ba869ec581fd9078b684c56c399ffe3d2345e27
acer-wmi: fix regression in backlight detection

shipped upstream in 2.6.29-rc

closed

Note You need to log in before you can comment on or make changes to this bug.