Bug 12833 - mtd: physmap: NULL pointer dereference in error path
mtd: physmap: NULL pointer dereference in error path
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-03-07 12:43 UTC by Rafael J. Wysocki
Modified: 2009-03-14 13:31 UTC (History)
0 users

See Also:
Kernel Version: commit e480814f138cd5d78a8efe397756ba6b6518fdb6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-07 12:43:33 UTC
Subject    : [PATCH] mtd: physmap: Fix NULL pointer dereference in error path
Submitter  : Atsushi Nemoto <anemo@mba.ocn.ne.jp>
Date       : 2009-03-06 1:43
References : http://marc.info/?l=linux-kernel&m=123630385119025&w=4
Handled-By : Atsushi Nemoto <anemo@mba.ocn.ne.jp>
Patch      : http://marc.info/?l=linux-kernel&m=123630385119025&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit e480814f138cd5d78a8efe397756ba6b6518fdb6
Author: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
Date:   Wed Feb 11 13:12:17 2009 -0800

    [MTD] [MAPS] physmap: fix wrong free and del_mtd_{partition,device}

    Signed-off-by: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
    Reported-by: Matthias Kaehlcke <matthias@kaehlcke.net>
    Tested-by: Matthias Kaehlcke <matthias@kaehlcke.net>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>

First-Bad-Commit : e480814f138cd5d78a8efe397756ba6b6518fdb6
Comment 1 Rafael J. Wysocki 2009-03-14 13:31:06 UTC
Fixed by commit d58ab5cf09679d8cb4824e22cae900c0eab5ab31 .

Note You need to log in before you can comment on or make changes to this bug.