Bug 12816 - sony-laptop infunctional on Sony Vaio VGN-TT11/LN
sony-laptop infunctional on Sony Vaio VGN-TT11/LN
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Mattia Dongili
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-03-04 02:35 UTC by Michael Wallner
Modified: 2013-04-09 06:23 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.28.7
Tree: Mainline
Regression: No


Attachments
dmesg | grep -i sony (3.90 KB, text/plain)
2009-03-04 02:37 UTC, Michael Wallner
Details
dmesg (38.11 KB, text/plain)
2009-03-05 03:44 UTC, Michael Wallner
Details
DSDT (375.59 KB, text/plain)
2009-03-05 03:44 UTC, Michael Wallner
Details
lscpi -xvvv (20.05 KB, text/plain)
2009-03-05 03:45 UTC, Michael Wallner
Details
dmidecode (7.17 KB, text/plain)
2009-03-05 03:45 UTC, Michael Wallner
Details
try to enable extra features on Vaio TT (634 bytes, patch)
2009-03-11 05:50 UTC, Mattia Dongili
Details | Diff
Extra handling for new SNC models (5.69 KB, patch)
2009-03-21 04:36 UTC, Mattia Dongili
Details | Diff
kernel messages (298.45 KB, text/plain)
2009-03-23 14:05 UTC, Michael Wallner
Details
various - dmesg/lspci/dmidecode etc (9.05 KB, application/zip)
2009-05-08 08:29 UTC, Spencer Goh
Details
dmesg, sony-laptop debug=1 (64.91 KB, text/plain)
2009-05-08 11:50 UTC, Spencer Goh
Details

Description Michael Wallner 2009-03-04 02:35:38 UTC
Distribution: ARCH
Hardware Environment: Sony Vaio VGN-TT11/LN
Problem Description: most features of sony-laptop are infunctional

Steps to reproduce:

Though wwan is powered on:
[mike@pygmytarsier ~]$ cat /sys/devices/platform/sony-laptop/wwanpower 
0
Echo has no effect either.

Bluetooth:
[root@pygmytarsier ~]# hcitool scan
Scanning ...
	00:1B:59:4C:6B:E8	M600i
	00:14:A4:8C:43:68	SEAG0158
[root@pygmytarsier ~]# cat /sys/devices/platform/sony-laptop/bluetoothpower 
255
[root@pygmytarsier ~]# echo 0 > /sys/devices/platform/sony-laptop/bluetoothpower 
[root@pygmytarsier ~]# tail -n3 /var/log/kernel.log 
Mar  4 11:19:51 pygmytarsier sony-laptop: sony_pic_call2(0x96 - 0x00): 0x00ff
Mar  4 11:19:51 pygmytarsier sony-laptop: sony_pic_call1(0x82): 0xff0a
Mar  4 11:19:51 pygmytarsier sony-laptop: event ([ff] [04]) at port 0xc000(+0x12)
[root@pygmytarsier ~]# hcitool scan
Scanning ...
	00:14:A4:8C:43:68	SEAG0158
	00:1B:59:4C:6B:E8	M600i
[root@pygmytarsier ~]# cat /sys/devices/platform/sony-laptop/bluetoothpower 
0

[root@pygmytarsier ~]# cat /sys/devices/platform/sony-laptop/fanspeed 
17
[root@pygmytarsier ~]# echo 10 > /sys/devices/platform/sony-laptop/fanspeed 
# no event messages
[root@pygmytarsier ~]# cat /sys/devices/platform/sony-laptop/fanspeed 
17

Shouldn't there also be wlanpower?
[root@pygmytarsier ~]# grep . /sys/devices/platform/sony-laptop/*
/sys/devices/platform/sony-laptop/PID:13
/sys/devices/platform/sony-laptop/bluetoothpower:0
/sys/devices/platform/sony-laptop/fanspeed:17
/sys/devices/platform/sony-laptop/modalias:platform:sony-laptop
/sys/devices/platform/sony-laptop/uevent:DRIVER=sony-laptop
/sys/devices/platform/sony-laptop/uevent:PHYSDEVBUS=platform
/sys/devices/platform/sony-laptop/uevent:PHYSDEVDRIVER=sony-laptop
/sys/devices/platform/sony-laptop/uevent:MODALIAS=platform:sony-laptop
/sys/devices/platform/sony-laptop/wwanpower:0

FKeys/PKeys [Fn]+FXX (brightness, vga, zoom) and 2 of the PKeys (S1, eject) don't work either.

sony-laptop seems to register a JogDial device which I don't have (at least as far as I can tell).
Comment 1 Michael Wallner 2009-03-04 02:37:40 UTC
Created attachment 20424 [details]
dmesg | grep -i sony
Comment 2 Zhang Rui 2009-03-04 16:47:15 UTC
re-assign to Mattia
Comment 3 Mattia Dongili 2009-03-04 18:46:39 UTC
Michael,

could you also attach the DSDT, the full dmesg, lspci and dmidecode?
Thanks

-- mattia 
Comment 4 Michael Wallner 2009-03-05 03:44:17 UTC
Created attachment 20437 [details]
dmesg
Comment 5 Michael Wallner 2009-03-05 03:44:50 UTC
Created attachment 20438 [details]
DSDT
Comment 6 Michael Wallner 2009-03-05 03:45:15 UTC
Created attachment 20439 [details]
lscpi -xvvv
Comment 7 Michael Wallner 2009-03-05 03:45:34 UTC
Created attachment 20440 [details]
dmidecode
Comment 8 Zhang Rui 2009-03-10 23:56:21 UTC
Ping mattia. :)
Comment 9 Mattia Dongili 2009-03-11 05:49:52 UTC
errr... sorry.
This model seems to have a few different features than the other models (as usual). The SPIC device is surprisingly different and the bluetooth and wwan power and fanspeed features depend on it.
The attached patch might improve things a little bit for Fn keys, could you give it a try?

thanks
Comment 10 Mattia Dongili 2009-03-11 05:50:58 UTC
Created attachment 20490 [details]
try to enable extra features on Vaio TT
Comment 11 Mattia Dongili 2009-03-11 06:17:09 UTC
Michael,
I forgot to mention that the patch applies on top of what I have recently sent to the linux-acpi ML a few days ago:
http://marc.info/?l=linux-acpi&m=123588303519697&w=2

I can resend the whole batch to you privately if you prefer.
Comment 12 Zhang Rui 2009-03-11 20:24:33 UTC
so this bug can be marked as RESOLVED and PATCH_ALREADY_AVAILABLE, right?
Comment 13 Mattia Dongili 2009-03-11 20:59:08 UTC
Not sure what that is going to enable though.
I'd rather wait for the submitter to at least give some feedback about it.
Comment 14 Michael Wallner 2009-03-12 01:02:23 UTC
Sorry no, I don't think this bug is bug is resolved yet.
I'll need the weekend to cleanup an repatch my sony-laptop.c with the patchset of linux-acpi@ and this little attachemnt.

Actually, I already had hacked Type3 support for ICH9 and enabling the SNC routine for VGN-TT -- without success.

Anyway, I'll try again with the official patches and report back ASAP.
Thank you.
Comment 15 Michael Wallner 2009-03-17 02:43:05 UTC
Applied paches 1-9 plus above attachment to no avail.
Comment 16 Zhang Rui 2009-03-17 19:14:52 UTC
(In reply to comment #15)
> Applied paches 1-9 plus above attachment to no avail.
> 
sorry, what do you mean?
you have applied the patch set from Mattia, right?
does the patch set work for you?
Comment 17 Michael Wallner 2009-03-20 05:19:00 UTC
I applied Mattias patchset from linux-acpi@ and the patch from comment #10.

It didn't help (== to no avail).
Comment 18 Mattia Dongili 2009-03-21 04:35:48 UTC
Michael,

the attached patch from Matthew Garret should help you, can you give it a go?
thanks
Comment 19 Mattia Dongili 2009-03-21 04:36:46 UTC
Created attachment 20619 [details]
Extra handling for new SNC models
Comment 20 Michael Wallner 2009-03-23 14:03:49 UTC
That definitely does "something" _good_.

Seems that all rfkill device interfaces work. Devices get initialized nicely and are even available after cold booting Linux.  Seems that hso-7 and 5100AGN rfkill nodes are connected/descendant to/of the sony-wwan resp. sony-wifi nodes. Disabling the sony-wwan while connected results in a kernel oops though. Resume seems to be handled nicely too.  sony-laptop now even receives unknown events when pressing EJECT or Fn+FX respectively using the rfkill switch.

I'll attache the kernel log of this session.
This results were taken with sony-laptop of Linux-2.6.28 + above patch from Matthew Garret + forcing Type3 model.
Comment 21 Michael Wallner 2009-03-23 14:05:30 UTC
Created attachment 20651 [details]
kernel messages
Comment 22 Zhang Rui 2009-03-30 06:26:55 UTC
> This results were taken with sony-laptop of Linux-2.6.28 + above patch from
> Matthew Garret + forcing Type3 model.

All the patches mentioned above is queued for 2.6.30, right?

Now there are two problems left,
1. kernel oops when disabling the sony-wwan while connected.
2. reveive unknown events when pressing EJECT or Fn+Fx key using rfkill switch.

Michael,
can you get the screenshot of the kernel oops and attach it here?

Mattia,
is this a known issue? can you look at this?
Comment 23 Mattia Dongili 2009-03-30 09:28:09 UTC
1) is not known. But looking at the log sony-laptop was not loaded when the oops occurred.

2) is known and should be fixed with the patch submitted to Len (also available in one single patch here: http://kamineko.org/sony-laptop-2.6.30.patch)

Zhang, the oops in the attachment at comment #21.
Comment 24 Spencer Goh 2009-04-09 17:19:59 UTC
I also have this laptop and have found similar problems to those listed above.
I'd be interested in helping out with any further testing.

Also I have thus far not managed to get my 3G modem Options Globetrotter HSDPA modem working, is it at all related to this driver?  I believe it has to be powered on in the same way

Currently on 2.6.27.21 kernel
Thanks
Comment 25 Mattia Dongili 2009-04-11 02:44:09 UTC
(In reply to comment #24)
> I also have this laptop and have found similar problems to those listed above.
> I'd be interested in helping out with any further testing.

did you try the proposed patch already?
Note also that that code (with additional fixes) is in 2.6.30-rc1

> Also I have thus far not managed to get my 3G modem Options Globetrotter HSDPA
> modem working, is it at all related to this driver?  I believe it has to be
> powered on in the same way

Yes, the current (2.6.30-rc1) sony-laptop should be able to power the modem on and off.

Thanks
Comment 26 Zhang Rui 2009-05-05 02:29:38 UTC
ping Spencer.
what's the status after upgrading the kernel to 2.6.30-rc?
Comment 27 Spencer Goh 2009-05-08 08:20:55 UTC
I upgraded kernel-firmware & kernel to 2.6.30-rc4 downloaded from koji, but have no luck with this one.... have I missed something?

 - FN laptop brightness is non-functional
 - Eject button, non-functional (was ok with 2.6.29.2)
 - Mute speaker button doesn't work

Incidentally my gnome-terminal also has problems (window disappears immediately)
Attachments to follow...
Comment 28 Spencer Goh 2009-05-08 08:29:21 UTC
Created attachment 21274 [details]
various - dmesg/lspci/dmidecode etc

running 2.6.30-rc4 kernel from 
http://kojipkgs.fedoraproject.org/packages/kernel/2.6.30/0.78.rc4.git3.fc12/
Comment 29 Mattia Dongili 2009-05-08 10:43:46 UTC
(In reply to comment #27)
> I upgraded kernel-firmware & kernel to 2.6.30-rc4 downloaded from koji, but
> have no luck with this one.... have I missed something?
> 
>  - FN laptop brightness is non-functional
>  - Eject button, non-functional (was ok with 2.6.29.2)
>  - Mute speaker button doesn't work

these could be related to sony-laptop, can you please:
1. unload the module (rmmod sony-laptop)
2. reload it with debug=1 (modprobe sony-laptop debug=1)
3. press the non-working buttons
4. attach the full (no grepping please) dmesg to this bug

thanks a lot
-- mattia
Comment 30 Spencer Goh 2009-05-08 11:50:20 UTC
Created attachment 21276 [details]
dmesg, sony-laptop debug=1

Full dmesg output with sony-laptop module loaded with debug=1
Comment 31 Mattia Dongili 2009-05-09 02:26:07 UTC
all of the key-presses have been recognized by the driver, this is a gnome/hal/whatever configuration issue.
You should be able to see the keypress activity with xev while in X.

The brightness has to be controlled via the acpi video driver so as far as sony-laptop is concerned this bug is fixed.

-- mattia
Comment 32 Len Brown 2009-05-16 02:37:44 UTC
so if the acpi video driver is handling brightness -- does it work?
(it works on my sony)
Comment 33 Zhang Rui 2009-05-22 03:09:46 UTC
ping Spencer
Comment 34 Adrian Ulrich 2009-05-23 19:30:43 UTC
I own a VGN-TT11WN and can confirm that 2.6.30-rcX fixes all sony-laptop problems for this model:

 - all 'hotkeys' are working
 - suspend works
 - video brightness adjustment works
 - wwanpower works

Regards,
 Adrian
Comment 35 Zhang Rui 2009-05-25 03:17:12 UTC
good news.
Adrain, thanks for confirming this.
close this bug.
Comment 36 dr.hubertschmidt 2010-11-04 13:48:26 UTC
Please open this bug again. 

fanspeed problem is not solved at all. fan is running all the time and /sys/devices/platform/sony-laptop/fanspeed cannot be changed.

/sys/devices/platform/sony-laptop/fanspeed  is usefull for reporting the speed and not for changing.

Note You need to log in before you can comment on or make changes to this bug.