Bug 12808 - Suspend regression with 2.6.29-rc
Suspend regression with 2.6.29-rc
Status: CLOSED DOCUMENTED
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-03-02 13:39 UTC by Rafael J. Wysocki
Modified: 2009-04-02 05:03 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-02 13:39:52 UTC
Subject    : Suspend regression with 2.6.29-rc
Submitter  : Tino Keitel <tino.keitel@gmx.de>
Date       : 2009-02-24 19:08
References : http://marc.info/?l=linux-kernel&m=123550257312112&w=4
Handled-By : "Rafael J. Wysocki" <rjw@sisk.pl>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-03-02 13:40:25 UTC
Tino, please provide the information as requested in the e-mail thread.
Comment 2 Zhang Rui 2009-03-18 20:08:11 UTC
ping Tino. :)
Comment 3 Tino Keitel 2009-03-19 00:15:50 UTC
I tried 2.6.29-rc8-00223-ga1e4ee2 without success. With X running, the computer hangs during suspend. Without X and init=/bin/sh, the text console is black after resume, so I can't get anyting usable with 2.6.29-rc.
Comment 4 Tino Keitel 2009-03-24 13:09:01 UTC
I tested the 2.6.29 release and saw the following:

- with KMS enabled and X running, the kernel hangs at suspend

- with a .config from 2.6.27 and being conservative in make oldconfig (and so keeping KMS disabled), suspend worked at least 2 times in a row with X running


Comment 5 Rafael J. Wysocki 2009-03-28 21:29:31 UTC
In fact suspend-resume is not guaranteed to work with KMS enabled, as far as I can say.

So, if it works with KMS disabled, I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.