Bug 12806 - i915 broken STR
i915 broken STR
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-03-02 13:22 UTC by Rafael J. Wysocki
Modified: 2009-03-15 03:34 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-03-02 13:22:49 UTC
Subject    : [2.6.29-rc6 regression][bisected] i915 broken STR
Submitter  : Harvey Harrison <harvey.harrison@gmail.com>
Date       : 2009-02-28 4:20
References : http://marc.info/?l=linux-kernel&m=123579487801064&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 5669fcacc58bf3a7386057addffd280d75380858
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Tue Feb 17 15:13:31 2009 -0800

    drm/i915: suspend/resume GEM when KMS is active

    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
    Signed-off-by: Eric Anholt <eric@anholt.net>
    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 5669fcacc58bf3a7386057addffd280d75380858
Comment 1 Rafael J. Wysocki 2009-03-07 13:24:45 UTC
On Wednesday 04 March 2009, Harvey Harrison wrote:
> On Tue, 2009-03-03 at 20:25 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12806
> > Subject		: i915 broken STR
> > Submitter	: Harvey Harrison <harvey.harrison@gmail.com>
> > Date		: 2009-02-28 4:20 (4 days old)
> 
> Still present in -rc7, let me know what info you need to help debug.

Comment 2 Rafael J. Wysocki 2009-03-07 13:25:17 UTC
On Saturday 07 March 2009, Harvey Harrison wrote:
> On Tue, 2009-03-03 at 20:25 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12806
> > Subject		: i915 broken STR
> > Submitter	: Harvey Harrison <harvey.harrison@gmail.com>
> > Date		: 2009-02-28 4:20 (4 days old)
> 
> This looks to have been a case of old-userspace..upgrading to
> xorg-intel-video 2.6.1 (ubuntu Jaunty Alpha5) fixes STR here.

Comment 3 Rafael J. Wysocki 2009-03-15 03:32:39 UTC
On Sunday 15 March 2009, Harvey Harrison wrote:
> On Sat, 2009-03-14 at 20:05 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12806
> > Subject		: i915 broken STR
> > Submitter	: Harvey Harrison <harvey.harrison@gmail.com>
> > Date		: 2009-02-28 4:20 (15 days old)
> > 
> > 
> 
> You can close this, turns out KMS got enabled in my config and userspace
> was too old to cope.


Note You need to log in before you can comment on or make changes to this bug.