Bug 12769 - 3D performance gets very choppy after suspend/resume cycle (intel video)
3D performance gets very choppy after suspend/resume cycle (intel video)
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-02-23 23:36 UTC by Michael
Modified: 2009-04-17 09:02 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Michael 2009-02-23 23:36:35 UTC
Latest working kernel version: 2.6.27.10
Earliest failing kernel version: 2.6.29-rc5 (haven't tested any in between)
Distribution: Debian SID (+ some components from experimental)
Hardware Environment:
Thinkpad X200s, Intel Graphics Media Accelerator 4500MHD

Software Environment:
xserver-xorg 1:7.4~5, xserver-xorg-video-intel 2:2.6.1-1, libgl1-mesa-dri 7.3-1, libgl1-mesa-dri 7.3-1

Problem Description:
Everything works perfectly (including 3D, e.g. compiz) until I suspend the laptop either to RAM or to disk. After successful resume 3D performance is very choppy, meaning it stops for half or quarter a second frequently. Even a restart of X does not get back to original performance. Whole laptop needs to be restarted for this.

Steps to reproduce:
Start laptop with kernel option vga=0, enter X, -> everything works
Switch to VT1 and back to VT7, _> everything still o.k.
Suspend to RAM or DISK, resume, back to X, -> choppy 3D
Leave X and restart X, -> still choppy 3D
Restart laptop, -> everything o.k. (until next suspend)
Comment 1 Michael 2009-02-24 01:07:30 UTC
Some additional info:

Just tested 2.6.29-rc6: Same problem

Strangely, it does not affect all 3D operations. E.g. in compiz you have no negative effect on window wobble, but zooming out to see the cube or rotating it is affected extremely strong
Comment 2 Michael 2009-02-26 00:04:35 UTC
Hmm, is there any information you need? Maybe kernel config? Some logs (although for me it seems there is nothing in)?

Shall I try to run the kernel with special debug options?

If I can do anything (that is within my capabilities), just tell me.

Thanks

Michael
Comment 3 Michael 2009-03-10 14:59:16 UTC
It seems nobody is interested?!

Fortunately, 2.6.27.10 works pretty perfectly on my machine (except a buffer problem in iwlagn), so I'll stay with that.

Cheers,

Michael
Comment 4 Sérgio M Basto 2009-03-10 17:18:53 UTC
Could not be kernel dri it self, but libgl1-mesa-dri 7.3-1
Mesa 7.3 still underdevelopment, thought and could be the reason of the problem, it hard to tell what is the problem. 
Seem report again may be intel drv or libdrm ... 
Comment 5 Michael 2009-03-11 01:57:00 UTC
Hi Sergio

Well, I'm by far no expert here, but it seems strange to me that the problem may lie in Mesa 7.3 or libdrm as there are no problems with just the same Mesa/libdrm under kernel 2.6.27.10.

But as I said, I'm no expert...

Cheers,

Michael
Comment 6 Michael 2009-03-13 00:46:24 UTC
Sergio,

it seems you are right. Strange, that I did not see that before, but now I also have the problem with 2.6.27.10 !

Probably with updating to 2.6.29 I also updated some other stuff (e.g. mesa), but somehow I didn't notice the problem with 2.6.27.10.

I changed the bug to rejected (hope that's the right term for it) and am now trying to find out where the problem is. Need to find older versions from mesa etc (will look for snapshots of debian respsitories).

Thank you very much for the hint. Otherwise, it might have taken much more time until I realize that it is not the kernel.

Michael
Comment 7 Michael 2009-04-17 09:02:07 UTC
Great, great, great!

I managed to solve my problem. After hours and days of trying different drivers, libs, kernels, whatsoever, with no success at all, I found the final solution today by pure conincidence. 

Switching from default EXA to UXA acceleration seems to solve all problems:

- No more freezes / choppy 3D after suspend/resume
- As a goody: Googleearth now displays correctly (there was nothing visible before) and glxgears also soared from 50fps to 600fps.

I'm not sure whether I also need to enable KMS (I have no idea how to do that anyway), but for now I'm very happy with my usable laptop again.

Cheers,

Michael

P.S.: I am now using latest drivers and kernels from Debian SID, namely:
xserver-xorg 7.4
xserver-xorg-core 1.6.1
xserver-xorg-video-intel 2.7.0-1
libgl1-mesa-dri/glx 7.4-2
libdrm2 2.4.9

Note You need to log in before you can comment on or make changes to this bug.