Bug 12765 - i915 VT switch with AIGLX causes X lock up
i915 VT switch with AIGLX causes X lock up
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-23 15:35 UTC by Rafael J. Wysocki
Modified: 2009-07-26 22:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-23 15:35:57 UTC
Subject    : [REGRESSION] i915 VT switch with AIGLX causes X lock up
Submitter  : Sitsofe Wheeler <sitsofe@yahoo.com>
Date       : 2009-02-21 15:38
References : http://marc.info/?l=linux-kernel&m=123523074304955&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-26 14:32:09 UTC
On Thursday 26 February 2009, Sitsofe Wheeler wrote:
> On Mon, Feb 23, 2009 at 10:48:18PM +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12765
> > Subject		: i915 VT switch with AIGLX causes X lock up
> > Submitter	: Sitsofe Wheeler <sitsofe@yahoo.com>
> > Date		: 2009-02-21 15:38 (3 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123523074304955&w=4
> 
> Yes, this should be still listed -
> http://marc.info/?l=dri-devel&m=123546141010034&w=4 (occurs with
> 2.6.29-rc6).

Comment 2 Rafael J. Wysocki 2009-03-14 11:39:56 UTC
Caused by:

commit 14d200c5e5bd19219d930bbb9a5a22758c8f5bec
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Fri Feb 6 13:04:49 2009 -0800

    drm/i915: capture last_vblank count at IRQ uninstall time too

    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
    Acked-by: Michel Dänzer <michel@daenzer.net>
    Tested-by: Timo Aaltonen <tjaalton@cc.hut.fi>
    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 14d200c5e5bd19219d930bbb9a5a22758c8f5bec
Comment 3 Rafael J. Wysocki 2009-03-19 06:03:33 UTC
On Monday 16 March 2009, Sitsofe Wheeler wrote:
> On Sat, Mar 14, 2009 at 08:05:32PM +0100, Rafael J. Wysocki wrote:
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12765
> > Subject		: i915 VT switch with AIGLX causes X lock up
> > Submitter	: Sitsofe Wheeler <sitsofe@yahoo.com>
> > Date		: 2009-02-21 15:38 (22 days old)
>
> Still here in 2.6.29-rc8.

Comment 4 Rafael J. Wysocki 2009-04-26 11:10:29 UTC
Notify-Also : DRI <dri-devel@lists.sourceforge.net>
Comment 5 Rafael J. Wysocki 2009-04-28 21:43:19 UTC
References : http://lkml.org/lkml/2009/4/27/317
Comment 6 Rafael J. Wysocki 2009-04-28 21:45:44 UTC
Handled-By : Jesse Barnes <jbarnes@virtuousgeek.org>
Patch : http://patchwork.kernel.org/patch/20197/
Comment 7 Rafael J. Wysocki 2009-05-18 17:11:26 UTC
On Monday 18 May 2009, Sitsofe Wheeler wrote:
> On Sat, May 16, 2009 at 10:05:57PM +0200, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12765
> > Subject		: i915 VT switch with AIGLX causes X lock up
> > Submitter	: Sitsofe Wheeler <sitsofe@yahoo.com>
> > Date		: 2009-02-21 15:38 (85 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=14d200c5e5bd19219d930bbb9a5a22758c8f5bec
> > References	: http://marc.info/?l=linux-kernel&m=123523074304955&w=4
> > 		  http://lkml.org/lkml/2009/4/27/317
> > Handled-By	: Jesse Barnes <jbarnes@virtuousgeek.org>
> > Patch		: http://patchwork.kernel.org/patch/20197/
> 
> Yes, this problem is still here in 2.6.30-rc6-00026-g0f6f49a .
Comment 8 Sitsofe Wheeler 2009-05-20 12:04:24 UTC
As this is still happening in the kernel should this bug remain resolved (I do not know what the protocol is in this bugzilla)?
Comment 9 Rafael J. Wysocki 2009-05-26 23:12:06 UTC
On Wednesday 27 May 2009, Sitsofe Wheeler wrote:
> On Sun, May 24, 2009 at 09:31:15PM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.28 and 2.6.29.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12765
> > Subject		: i915 VT switch with AIGLX causes X lock up
> > Submitter	: Sitsofe Wheeler <sitsofe@yahoo.com>
> > Date		: 2009-02-21 15:38 (93 days old)
> 
> Yes this is still here in  2.6.30-rc7-00066-ge2a1b9e ...
Comment 10 Rafael J. Wysocki 2009-06-01 20:09:53 UTC
On Sunday 31 May 2009, Sitsofe Wheeler wrote:
> On Sat, May 30, 2009 at 09:55:33PM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.28 and 2.6.29.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12765
> > Subject		: i915 VT switch with AIGLX causes X lock up
> > Submitter	: Sitsofe Wheeler <sitsofe@yahoo.com>
> > Date		: 2009-02-21 15:38 (99 days old)
> 
> Still here in 2.6.30-rc7-00149-g3218911. I have to admit that I thought
> commit 9b6fe313bfce27d4a261257da70196be0ac2bef5 might fix it but that
> doesn't appear to have been the case...
Comment 11 Rafael J. Wysocki 2009-07-26 22:43:55 UTC
On Monday 20 July 2009, Jesse Barnes wrote:
> On Sun, 28 Jun 2009 21:11:30 +0100
> Sitsofe Wheeler <sitsofe@yahoo.com> wrote:
> 
> > On Sun, Jun 07, 2009 at 12:06:18PM +0200, Rafael J. Wysocki wrote:
> > > 
> > > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12765
> > > Subject		: i915 VT switch with AIGLX causes X lock up
> > > Submitter	: Sitsofe Wheeler <sitsofe@yahoo.com>
> > > Date		: 2009-02-21 15:38 (107 days old)
> > > First-Bad-Commit:
> > > http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=14d200c5e5bd19219d930bbb9a5a22758c8f5bec
> > > References	:
> > > http://marc.info/?l=linux-kernel&m=123523074304955&w=4
> > > http://lkml.org/lkml/2009/4/27/317 Handled-By	: Jesse Barnes
> > > <jbarnes@virtuousgeek.org> Patch		:
> > > http://patchwork.kernel.org/patch/20197/
> > 
> > Still here on 2.6.31-rc1 but...
> > 
> > ...this seems to be tied to the version of the Intel X drivers I have.
> > On another install with more recent Intel X drivers I cannot reproduce
> > this issue.
> 
> I guess we can mark it closed then, though I don't have the commit id
> of the fix handy...

Note You need to log in before you can comment on or make changes to this bug.