Bug 12762 - Disk errors loop forever in 2.6.29
Disk errors loop forever in 2.6.29
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-23 15:11 UTC by Rafael J. Wysocki
Modified: 2009-03-03 14:14 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-23 15:11:12 UTC
Subject    : [SCSI][REGRESSION][BISECTED] Disk errors loop forever in 2.6.29
Submitter  : Sitsofe Wheeler <sitsofe@yahoo.com>
Date       : 2009-02-19 13:53
References : http://marc.info/?l=linux-kernel&m=123505185407604&w=4
Handled-By : James Bottomley <James.Bottomley@hansenpartnership.com>
Patch      : http://marc.info/?l=linux-kernel&m=123508030726900&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-23 15:13:33 UTC
Caused by:

commit b60af5b0adf0da24c673598c8d3fb4d4189a15ce
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Mon Nov 3 15:56:47 2008 -0500

    [SCSI] simplify scsi_io_completion()

    Signed-off-by: Alan Stern <stern@rowland.harvard.edu>
    Signed-off-by: James Bottomley <James.Bottomley@HansenPartnership.com>

First-Bad-Commit : b60af5b0adf0da24c673598c8d3fb4d4189a15ce

Note You need to log in before you can comment on or make changes to this bug.