Bug 12760 - 2.6.29-rc5 hanging at boot when CONFIG_LOCK_STAT=y
2.6.29-rc5 hanging at boot when CONFIG_LOCK_STAT=y
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-23 14:53 UTC by Rafael J. Wysocki
Modified: 2009-02-25 15:12 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-23 14:53:55 UTC
Subject    : 2.6.29-rc5 hanging at boot when CONFIG_LOCK_STAT=y
Submitter  : "Adam J. Richter" <adam@yggdrasil.com>
Date       : 2009-02-16 6:50
References : http://marc.info/?l=linux-kernel&m=123476768023893&w=4
Handled-By : Ingo Molnar <mingo@elte.hu>
Notify-Also : Peter Zijlstra <peterz@infradead.org>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-25 15:10:43 UTC
On Tuesday 24 February 2009, Ingo Molnar wrote:
> 
> (note, the standalone mail of this bug entry did not make it out 
> for some reason.)
> 
> * Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12760
> > Subject		: 2.6.29-rc5 hanging at boot when CONFIG_LOCK_STAT=y
> > Submitter	: Adam J. Richter <adam@yggdrasil.com>
> > Date		: 2009-02-16 6:50 (8 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123476768023893&w=4
> > Handled-By	: Ingo Molnar <mingo@elte.hu>
> 
> Here we came to the conclusion that this is some LILO bug with a 
> too large BSS section - that's one thing that CONFIG_LOCK_STAT 
> causes. Under Grub the same kernel image boots fine. So unless 
> Adam has new data that contradicts this i think we can close 
> this bug.


Note You need to log in before you can comment on or make changes to this bug.