Bug 12758 - ACPI exception with 2.6.29-rc6
ACPI exception with 2.6.29-rc6
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
All Linux
: P1 normal
Assigned To: Len Brown
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-23 14:34 UTC by Rafael J. Wysocki
Modified: 2009-03-17 10:00 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc6
Tree: Mainline
Regression: Yes


Attachments
Here comes the output of "acpidump" (101.14 KB, text/plain)
2009-02-24 06:47 UTC, Heinz Diehl
Details
revert offending patch from 2.6.29-rc6 (2.51 KB, patch)
2009-02-25 15:03 UTC, Len Brown
Details | Diff

Description Rafael J. Wysocki 2009-02-23 14:34:41 UTC
Subject    : ACPI exception with 2.6.29-rc6
Submitter  : Heinz Diehl <htd@fancy-poultry.org>
Date       : 2009-02-23 16:46
References : http://marc.info/?l=linux-kernel&m=123540758700861&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Heinz Diehl 2009-02-24 06:47:59 UTC
Created attachment 20350 [details]
Here comes the output of "acpidump"
Comment 2 Len Brown 2009-02-25 15:03:55 UTC
Created attachment 20368 [details]
revert offending patch from 2.6.29-rc6

Thanks for the acpidump.

The DSDT does indeed defines an opregion covering the ELCR:

    OperationRegion (ELCR, SystemIO, 0x04D0, 0x02)
    Field (ELCR, ByteAcc, NoLock, Preserve)
    {
        ELC1,   8,
        ELC2,   8
    }

However, no AML in the system actually references this opregion,
so the Linux warning is a false positive.

Bob Moore pointed out that if we checked our illegal IO port
address list at run-time rather than init-time, then we'd not
have any warnings on this box; and he volunteered to put that
check into upstream ACPICA.

So I'll delete the init-time check from Linux (we've lived without
it from pre-history until 2.6.29-rc) and we'll test the run-time
ACPICA address validation when it becomes available.
Comment 3 Rafael J. Wysocki 2009-03-07 14:11:14 UTC
On Wednesday 04 March 2009, Zhang Rui wrote:
> On Wed, 2009-03-04 at 03:22 +0800, Rafael J. Wysocki wrote:
> 
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=12758
> > Subject         : ACPI exception with 2.6.29-rc6
> > Submitter       : Heinz Diehl <htd@fancy-poultry.org>
> > Date            : 2009-02-23 16:46 (9 days old)
> > References      : http://marc.info/?l=linux-kernel&m=123540758700861&w=4
> > 
> Handled by: Len Brown <len.brown@intel.com>
> Patch-available:
> http://bugzilla.kernel.org/attachment.cgi?id=20368&action=view

Handled-By : Len Brown <lenb@kernel.org>
Patch : http://bugzilla.kernel.org/attachment.cgi?id=20368&action=view

Comment 4 Len Brown 2009-03-17 10:00:14 UTC
shipped upstream on top of 2.6.29-rc8-git2
closed.

Note You need to log in before you can comment on or make changes to this bug.