Bug 12757 - [BISECT]kernels later than 2.6.26.8 die at cardbus init on laptop
Summary: [BISECT]kernels later than 2.6.26.8 die at cardbus init on laptop
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ykzhao
URL:
Keywords:
: 12784 (view as bug list)
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2009-02-23 14:32 UTC by Rafael J. Wysocki
Modified: 2010-08-16 18:57 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-23 14:32:21 UTC
Subject    : [BUG] >2.6.27 dies at cardbus init on laptop
Submitter  : David Pflug <dtpflug@gmail.com>
Date       : 2009-02-17 19:28
References : http://marc.info/?l=linux-kernel&m=123489904218306&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 ykzhao 2009-02-23 17:37:59 UTC
Hi, David
    Will you please attach the output of acpidump, lspci -vxxx?
    It will be great if you can attach the output of dmesg when the following boot option is added:
    a. pci=noacpi
    b. noapic
    c. acpi=off
    
    Will you please confirm whether the box can be booted normally when using the previous kernel(2.6.26.x)? If so, it will be a regression.
   Will you please use git-bisect to identify the commit which causes the regression?
   thanks.
Comment 2 David Pflug 2009-02-26 23:12:00 UTC
*** Bug 12784 has been marked as a duplicate of this bug. ***
Comment 3 David Pflug 2009-02-26 23:44:24 UTC
noapic freezes at the same place. That was one of the first things I tried.

pci=noacpi:
http://pastebin.com/f1ee0c148

acpi=off:
http://pastebin.com/fc2898c4

lspci -vxxx:
http://pastebin.com/f738f61dd

acpidump:
http://pastebin.com/f56c9ed77

2.6.26 and the git-bisect will have to wait til the morn. I'm about to fall
asleep on the keys.
Comment 4 David Pflug 2009-02-27 07:37:58 UTC
2.6.26.8 boots fine. I'll get started on the git-bisect.
Comment 5 Rafael J. Wysocki 2009-03-02 14:42:44 UTC
Handled-By : Zhao Yakui <yakui.zhao@intel.com>

It turns out to be a regression from 2.6.26.8 (ie. before 2.6.27).  Moving to the other list.
Comment 6 ykzhao 2009-03-02 17:42:48 UTC
Hi, David
    Can the box be booted if the boot option of "noapic" is added?
    It will be great if you can use the git-bisect to identify the commit which causes the regression.
    Thanks.
Comment 7 David Pflug 2009-03-02 18:08:49 UTC
noapic was one of the first things I tried. It doesn't help.

git bisect says 5b34653963de7a6d0d8c783527457d68fddc60fb

I have no idea how those changes could be causing a problem, but there you go. I can post the full bisect log if you like.
Comment 8 David Pflug 2009-03-19 22:18:47 UTC
Is there anything else I can/should do for you?
Comment 9 David Pflug 2010-04-03 06:49:19 UTC
I don't know what changed, and doing a git bisect to figure out what's fixed would probably be a waste of time.

But it works with 2.6.33. :) Thanks!
Comment 10 Florian Mickler 2010-04-16 06:48:27 UTC
cool. so this bug can be closed.
Comment 11 Florian Mickler 2010-04-16 06:53:18 UTC
cool. so this bug can be closed.  

if you are up to an git-bisect for the fix, it could be backported to the stable trees. but don't feel obligated to it.

Note You need to log in before you can comment on or make changes to this bug.