Bug 12750 - ieee1394: hang at module removal
Summary: ieee1394: hang at module removal
Status: REJECTED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: IEEE1394 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_ieee1394
URL:
Keywords:
Depends on:
Blocks: 10046
  Show dependency tree
 
Reported: 2009-02-22 01:15 UTC by Stefan Richter
Modified: 2009-02-22 01:18 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc5 + few 1394 updates
Tree: Mainline
Regression: ---


Attachments

Description Stefan Richter 2009-02-22 01:15:34 UTC
Latest working kernel version: unknown
Earliest failing kernel version: unknown
Hardware Environment: SMP

"modprobe -r video1394" hangs.  "ps" and /proc show that the khpsbpkt kernel thread (which is responsible to finish transactions) was already removed, while the knodemgrd kernel thread hangs in hpsb_send_packet_and_wait().  modprobe hangs waiting for knodemgrd to be killed.

I.e. the problem is that khpsbpkt was terminated before all transactions were finished or that a new transaction was started after khpsbpkt was terminated.
Comment 1 Stefan Richter 2009-02-22 01:18:09 UTC
The newer alternative drivers/firewire/ stack did not exhibit any module removal deadlocks anymore lately.

Note You need to log in before you can comment on or make changes to this bug.