Bug 12735 - Sound don't work with my toshiba X200 and kernel 2.6.29
Sound don't work with my toshiba X200 and kernel 2.6.29
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Takashi Iwai
:
: 12810 (view as bug list)
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-17 23:14 UTC by chepioq
Modified: 2010-11-11 19:32 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments
output of war/log/dmesg (42.92 KB, application/octet-stream)
2009-02-17 23:52 UTC, chepioq
Details
codec.file (12.05 KB, text/plain)
2009-02-18 07:39 UTC, chepioq
Details
codec1.txt (25.11 KB, text/plain)
2009-02-18 10:10 UTC, chepioq
Details
/var/log/messages (1.66 KB, text/plain)
2009-02-18 22:18 UTC, chepioq
Details
/var/log/dmesg.txt (2.26 KB, text/plain)
2009-02-18 22:19 UTC, chepioq
Details
lspci-nv.txt (11.47 KB, text/plain)
2009-03-01 05:23 UTC, chepioq
Details
alsa-info.txt (19.19 KB, text/plain)
2009-03-01 05:24 UTC, chepioq
Details
Patch to fix Toshiba X200 probe on 2.6.29 (1.34 KB, patch)
2009-03-01 23:25 UTC, Takashi Iwai
Details | Diff

Description chepioq 2009-02-17 23:14:59 UTC
Latest working kernel version:2.6.28-3.fc11
Earliest failing kernel version:2.6.29-0.124.rc5.fc11
Distribution:Fedora 11 rawhide
Hardware Environment:00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Software Environment:Alsa, Pulseaudio
Problem Description:
I tested F11 rawhide and with the latest kernel (2.6.29) I have no sound.
I post a bug on bugzilla of Fedora (https://bugzilla.redhat.com/show_bug.cgi?id=485295 ) and they respond me it is a kernel bug...
I have sound with F11 rawhide and kernel 2.6.28

Tell me if you want any informations...
Thank
Chepioq
Comment 1 Takashi Iwai 2009-02-17 23:23:44 UTC
Please show the content of /proc/asound/cards (if any) and the kernel messages.
Comment 2 Takashi Iwai 2009-02-17 23:24:06 UTC
... and show your kernel config, too.
Comment 3 chepioq 2009-02-17 23:52:21 UTC
Created attachment 20294 [details]
output of war/log/dmesg
Comment 4 chepioq 2009-02-17 23:54:51 UTC
Output of /proc/asound/cards
[dominique@localhost ~]$ cat /proc/asound/cards
--- no soundcards ---
Where I found kernel message and kernel config?
I create an attachement for var/log/dmesg
Comment 5 Takashi Iwai 2009-02-17 23:59:11 UTC
Load snd-hda-intel module with probe_only=1 option.  Then give the contents of /proc/asound/card0/codec#* files.

I guess it'll work with probe_mask=1 option (without probe_only=1).
Comment 6 chepioq 2009-02-18 07:24:59 UTC
[dominique@localhost ~]$ modprobe_only=1 snd-hda-intel
bash: snd-hda-intel : commande introuvable
and I have not a /proc/asound/card0/ folder, I have just two folder: oss ans seq
Comment 7 chepioq 2009-02-18 07:38:59 UTC
For info I attach the content of /proc/asound/card0/codec#* for the 2.6.28 kernel
Comment 8 chepioq 2009-02-18 07:39:54 UTC
Created attachment 20296 [details]
codec.file
Comment 9 Takashi Iwai 2009-02-18 08:14:06 UTC
modprobe snd-hda-intel probe_only=1
Comment 10 Takashi Iwai 2009-02-18 08:18:44 UTC
Also try to build the kernel sound git tree from
    git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git
This contains the very latest ALSA tree.
Comment 11 chepioq 2009-02-18 08:46:36 UTC
Ok 
"modprobe snd-hda-intel probe_only=1"
don't return errors,but no sound and no /proc/asound/card0/ folder and no /proc/asound/card0/codec# files.
For comment #10 I don't know how do that....
Comment 12 Takashi Iwai 2009-02-18 09:18:36 UTC
First unload the module, then load it with the option.

modprobe won't complain and do anything when called for a module that is already present.
Comment 13 chepioq 2009-02-18 10:09:25 UTC
OK... I do 
[root@localhost ~]# rmmod snd-hda-intel
[root@localhost ~]# modprobe snd-hda-intel probe_only=1
and now I have a /proc/asound/card0/codec# files
I create and attachement file: codec1.txt
Comment 14 chepioq 2009-02-18 10:10:06 UTC
Created attachment 20298 [details]
codec1.txt
Comment 15 Rafael J. Wysocki 2009-02-18 12:28:53 UTC
Handled-By : Takashi Iwai <tiwai@suse.de>
Comment 16 chepioq 2009-02-18 22:18:03 UTC
For info I send you the output for sound of /var/log/messages and /var/log/dmesg

Comment 17 chepioq 2009-02-18 22:18:48 UTC
Created attachment 20310 [details]
/var/log/messages
Comment 18 chepioq 2009-02-18 22:19:46 UTC
Created attachment 20311 [details]
/var/log/dmesg.txt
Comment 19 Takashi Iwai 2009-02-18 22:55:44 UTC
Use probe_mask=0x1 (or probe_mask=0x3 if you need a modem) option as mentioned.
Comment 20 chepioq 2009-02-18 23:42:15 UTC
OK...
THAT WORK!!!!!
I do 
[root@localhost ~]# rmmod snd-hda-intel
[root@localhost ~]# modprobe snd-hda-intel probe_mask=0x1
I have sound, and alsamixer work...
But when I reboot I am obliged to do this two lines in console...
Thank a lot, Takashi Iwai
Comment 21 Alexey Dobriyan 2009-02-19 12:34:28 UTC
> But when I reboot I am obliged to do this two lines in console...

See modprobe.conf(5) manpage and "options" line.
Comment 22 Takashi Iwai 2009-03-01 01:44:35 UTC
Could you give the lspci -nv output?  I need to know the PCI SSID.  Is it 1179:ff00?

Or, at best, once load the driver with probe_only=1 option, then run alsa-info.sh script with --no-upload option, and attach the generated file.  The script is found at
    http://www.alsa-project.org/alsa-info.sh
Comment 23 chepioq 2009-03-01 05:23:25 UTC
Created attachment 20392 [details]
lspci-nv.txt
Comment 24 chepioq 2009-03-01 05:24:11 UTC
Created attachment 20393 [details]
alsa-info.txt
Comment 25 chepioq 2009-03-01 05:25:37 UTC
(In reply to comment #22)
> Could you give the lspci -nv output?  I need to know the PCI SSID.  Is it
> 1179:ff00?
> 
> Or, at best, once load the driver with probe_only=1 option, then run
> alsa-info.sh script with --no-upload option, and attach the generated file. 
> The script is found at
>     http://www.alsa-project.org/alsa-info.sh
> 
OK
I create two attachments: lspci-nv.txt and alsa-info.txt
Comment 26 Takashi Iwai 2009-03-01 23:11:41 UTC
Thanks.  Then it must be the same as Alexy has.
The patch below should fix the problem on 2.6.29 kernel.
Comment 27 chepioq 2009-03-01 23:21:24 UTC
(In reply to comment #26)
> Thanks.  Then it must be the same as Alexy has.
> The patch below should fix the problem on 2.6.29 kernel.
> 

Thank and ok
But where is this patch?
Comment 28 Takashi Iwai 2009-03-01 23:25:47 UTC
Created attachment 20403 [details]
Patch to fix Toshiba X200 probe on 2.6.29
Comment 29 chepioq 2009-03-01 23:48:09 UTC
Ok, thank for this patchbut...
I never apply a patch and I don't how to made this...
Do you tell me how can do it?
Comment 30 chepioq 2009-03-02 08:23:00 UTC
With help of fedora-fr community, I can patch the latest kernel of koji (2.6.29-0.176.rc6.git5.fc11.x86_64) and now I have sound...
Thank a lot Takashi Iwai.
Comment 31 Rafael J. Wysocki 2009-03-02 12:53:46 UTC
Patch : http://bugzilla.kernel.org/attachment.cgi?id=20403&action=view
Comment 33 Takashi Iwai 2009-03-02 22:46:21 UTC
*** Bug 12810 has been marked as a duplicate of this bug. ***
Comment 34 chepioq 2009-06-21 05:31:24 UTC
I reopen this bug:
I test actually Fedora12 rawhide, who have a 2.6.31 kernel, and there is same problem: no sound with my toshiba.
I do:
[root@localhost ~]# rmmod snd-hda-intel
[root@localhost ~]# modprobe snd-hda-intel probe_mask=0x1
 And I have sound.
I think that you have to do a patch for this kernel, like for kernel 2.6.29 (for kernel 2.6.30 they have not this problem...)
If you want, I can open a new bug rapport for this.
thank.
chepioq
Comment 35 Florian Mickler 2010-09-27 15:16:15 UTC
Is this still a problem?
Comment 36 Florian Mickler 2010-11-11 19:30:54 UTC
The patch that is reported to fix this should be in all mainline kernels as of 2.6.29-rc7. 

If you still have problems, it is unrelated to this bug, please open a new bug if you can still reproduce the new issue on current mainline kernels.

Note You need to log in before you can comment on or make changes to this bug.