Bug 12726 - sound/alsa/DocBook/* should be moved to DocBook/
sound/alsa/DocBook/* should be moved to DocBook/
Status: RESOLVED CODE_FIX
Product: Documentation
Classification: Unclassified
Component: man-pages
All Linux
: P1 normal
Assigned To: Randy Dunlap
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 09:43 UTC by Nicola Soranzo
Modified: 2012-03-02 13:26 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29-rc5
Tree: Mainline
Regression: No


Attachments

Description Nicola Soranzo 2009-02-17 09:43:40 UTC
Problem Description:
HTML and other documentation in not generated from DocBook files found in Documentation/sound/alsa/DocBook/ since there is no Makefile for them.
The most logical solution is to move the 2 files in Documentation/DocBook/ and add them to the relative Makefile.
Comment 1 Randy Dunlap 2009-02-26 14:10:59 UTC
Done. Patch is at http://oss.oracle.com/~rdunlap/patches/docbook-move-alsa-docs.patch
Comment 2 Takashi Iwai 2009-02-27 01:01:18 UTC
The patch can't be applied to the latest sound git tree, unfortunately.
Could you rebase the patch against it?
    git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git
Comment 3 Randy Dunlap 2009-02-27 10:57:19 UTC
Please try this new patch:
http://oss.oracle.com/~rdunlap/patches/docbook-move-alsa-docsv2.patch
Comment 4 Takashi Iwai 2009-02-28 08:43:24 UTC
Thanks, applied now.  Should appear in the next linux-next tree.

Note You need to log in before you can comment on or make changes to this bug.