Bug 12721 - Hibernation Resumes Immediately on Acer Aspire 1690
Hibernation Resumes Immediately on Acer Aspire 1690
Status: CLOSED DUPLICATE of bug 9258
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-02-16 13:54 UTC by Daniel Qarras
Modified: 2009-04-02 05:03 UTC (History)
1 user (show)

See Also:
Kernel Version: v2.6.29-rc5
Tree: Mainline
Regression: Yes


Attachments
dmidecode output from Acer Aspire 1690 (9.45 KB, text/plain)
2009-02-16 13:55 UTC, Daniel Qarras
Details
lspci -vvv output from Acer Aspire 1690 (22.97 KB, text/plain)
2009-02-16 13:56 UTC, Daniel Qarras
Details

Description Daniel Qarras 2009-02-16 13:54:01 UTC
Latest working kernel version: 2.6.23
Earliest failing kernel version: 2.6.24
Distribution: Fedora 10
Hardware Environment: Acer Aspire 1690
Software Environment: Fedora 10
Problem Description:
When running pm-hibernate on runlevel 3 the system nicely hibernates but immediately after that it resumes as if the power button had been pressed. Unloading the module ehci-hcd makes the system stay in the hibernation.

This issue has been discussed on pm-list:

https://lists.linux-foundation.org/pipermail/linux-pm/2009-January/019431.html
https://lists.linux-foundation.org/pipermail/linux-pm/2009-January/019225.html
https://lists.linux-foundation.org/pipermail/linux-pm/2009-January/019251.html
https://lists.linux-foundation.org/pipermail/linux-pm/2009-February/019825.html

I will attach output of dmidecode and lspci -vvv shortly.
Comment 1 Daniel Qarras 2009-02-16 13:55:52 UTC
Created attachment 20266 [details]
dmidecode output from Acer Aspire 1690
Comment 2 Daniel Qarras 2009-02-16 13:56:18 UTC
Created attachment 20267 [details]
lspci -vvv output from Acer Aspire 1690
Comment 3 ykzhao 2009-03-18 19:56:26 UTC
Hi, Rui
   Can this bug be marked as the duplicate of bug12643?
   From the problem description it seems that the issue can be fixed by unloading ehci-hcd module.
   thanks.
Comment 4 Zhang Rui 2009-03-18 20:05:46 UTC
The problem has already been fixed in the upstream kernel.
please try 2.6.28 and re-open this bug if the problem still exists.

*** This bug has been marked as a duplicate of bug 9258 ***

*** This bug has been marked as a duplicate of bug 9258 ***

Note You need to log in before you can comment on or make changes to this bug.