Bug 12710 - resume from disk slows down after a while (bisected)
resume from disk slows down after a while (bisected)
Status: CLOSED DUPLICATE of bug 12713
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 07:50 UTC by Markus Meier
Modified: 2009-02-15 12:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Markus Meier 2009-02-15 07:50:01 UTC
Latest working kernel version: 2.6.29-rc3
Earliest failing kernel version: 2.6.29-rc4
Distribution: Gentoo
Hardware Environment: HP Compaq nx7000
Software Environment:
Problem Description:
resuming from disk works, but after about 50-80% restoring, the speed goes rapidly down. it takes about 5 times longer to count up, but it "works" and resumes as expected.

Steps to reproduce: echo disk > /sys/power/state, resume after that.


$ git bisect log
git bisect start
# good: [18e352e4a73465349711a9324767e1b2453383e2] Linux 2.6.29-rc3
git bisect good 18e352e4a73465349711a9324767e1b2453383e2
# bad: [8e4921515c1a379539607eb443d51c30f4f7f338] Linux 2.6.29-rc4
git bisect bad 8e4921515c1a379539607eb443d51c30f4f7f338
# bad: [5c350d93ff4736086a1b08fef1d0b5e22138d2e0] Merge branch 'for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/drzeus/mmc
git bisect bad 5c350d93ff4736086a1b08fef1d0b5e22138d2e0
# good: [bb9f113f5ca7d182256dee69bcaebd4c79062305] headers_check fix: sound/hdsp.h
git bisect good bb9f113f5ca7d182256dee69bcaebd4c79062305
# bad: [2d2eca4d11933bd37a4944aae06e6122efffaea8] MIPS: Alchemy: time.c build fix
git bisect bad 2d2eca4d11933bd37a4944aae06e6122efffaea8
# bad: [ae704e9f92f87b12c5938b07245792857c7c9c14] Merge branch 'for-linus' of git://git.kernel.dk/linux-2.6-block
git bisect bad ae704e9f92f87b12c5938b07245792857c7c9c14
# good: [584dbe9475313e117abf9d2af88164edfd429c9a] netxen: fix memory leak in drivers/net/netxen_nic_init.c
git bisect good 584dbe9475313e117abf9d2af88164edfd429c9a
# bad: [7598909e3ee2a08726276d6415b69dadb52d0d76] Mark mandatory elevator functions in the biodoc.txt
git bisect bad 7598909e3ee2a08726276d6415b69dadb52d0d76
# good: [1308835ffffe6d61ad1f48c5c381c9cc47f683ec] block: export SSD/non-rotational queue flag through sysfs
git bisect good 1308835ffffe6d61ad1f48c5c381c9cc47f683ec
# bad: [dbdac9b71dff5d27885f82eb2cfca310861fdf9e] block: Fix documentation for blkdev_issue_flush()
git bisect bad dbdac9b71dff5d27885f82eb2cfca310861fdf9e
# bad: [1dfa17f4ab8543d82caf4d36636b93916a18f456] block: add bio_rw_flagged() for testing bio->bi_rw
git bisect bad 1dfa17f4ab8543d82caf4d36636b93916a18f456
# bad: [213d9417fec62ef4c3675621b9364a667954d4dd] block: seperate bio/request unplug and sync bits
git bisect bad 213d9417fec62ef4c3675621b9364a667954d4dd
Comment 1 Andrew Morton 2009-02-15 11:11:33 UTC
So.. Jens's 213d9417fec62ef4c3675621b9364a667954d4dd has been confirmed
to be the offending commit?

Comment 2 Rafael J. Wysocki 2009-02-15 12:38:44 UTC

*** This bug has been marked as a duplicate of bug 12713 ***

Note You need to log in before you can comment on or make changes to this bug.