Bug 12694 - Cant power off in Asus cusi-m
Cant power off in Asus cusi-m
Status: CLOSED DUPLICATE of bug 8549
Product: ACPI
Classification: Unclassified
Component: Power-Off
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 05:05 UTC by 邱焜
Modified: 2011-08-30 17:15 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
dmesg output (17.60 KB, application/octet-stream)
2009-02-14 03:59 UTC, 邱焜
Details
dmidecode output (11.13 KB, application/octet-stream)
2009-02-14 03:59 UTC, 邱焜
Details
lspci output (4.96 KB, application/octet-stream)
2009-02-14 03:59 UTC, 邱焜
Details
acpidump (34.97 KB, application/octet-stream)
2009-02-20 01:43 UTC, 邱焜
Details
use the ioport tool to access the 0xE404 I/O port directly (2.47 KB, patch)
2009-03-23 20:40 UTC, ykzhao
Details | Diff

Description 邱焜 2009-02-12 05:05:48 UTC
Latest working kernel version:Sorry, none.
Earliest failing kernel version:2.6.xx At least 2.6.16
Distribution:
Hardware Environment:ASUS CUSI-M with Pentium III (Coppermine) GenuineIntel
Software Environment:2.6.28-ARCH kernel with acpid
Problem Description:
Display "Power off" at the end of shutting without cut down the power.

Steps to reproduce:
Just shutdown

I tried to use commands as "halt -p" and add "apm=power_off" to menu.lst.
If you need any more information, ask me to post.
Comment 1 ykzhao 2009-02-12 17:19:19 UTC
Will you please attach the output of acpidump, lspci -vxxx, dmidecode, dmesg?
    
    Will you please add the following boot option and see whether the box can be shutdown?(Of course the CONFIG_APM should be set in kernel configuration).
    acpi=off apm="power_off" 
    Thanks.
Comment 2 邱焜 2009-02-14 03:59:00 UTC
Created attachment 20241 [details]
dmesg output
Comment 3 邱焜 2009-02-14 03:59:29 UTC
Created attachment 20242 [details]
dmidecode output
Comment 4 邱焜 2009-02-14 03:59:56 UTC
Created attachment 20243 [details]
lspci output
Comment 5 邱焜 2009-02-14 04:16:09 UTC
It's "power down" but not "power off". And i cant find acpidump. I always need to push the power button for cut down the power.

The options acpi=off apm="power_off" doesnt help any more. When i use apm, the power down faster than it down by acpi. But the problem is still not solved.
Comment 6 Zhang Rui 2009-02-16 01:15:39 UTC
You can get the acpidump using the latest pmtools here:
http://www.lesswatts.org/projects/acpi/utilities.php
Comment 7 邱焜 2009-02-20 01:43:58 UTC
Created attachment 20316 [details]
acpidump
Comment 8 ykzhao 2009-02-22 19:13:26 UTC
Hi, 
   This is a very old box. Even when the APM is used, it still can't be powered off.
   Will you please confirm whether the box can be powered off correctly on windows?
   
Comment 9 邱焜 2009-02-24 04:13:20 UTC
(In reply to comment #8)
> Hi, 
>    This is a very old box. Even when the APM is used, it still can't be powered
> off.
>    Will you please confirm whether the box can be powered off correctly on
> windows?
> 
> 
Sure, and it can.
Comment 10 ykzhao 2009-03-23 20:40:59 UTC
Created attachment 20655 [details]
use the ioport tool to access the 0xE404 I/O port directly

Will you please boot the box with acpi disabled and see whether the box can be shutdown by writing 0x1C01 to 0xE404 I/O directly?
    How to write 0x1C01 to 0xE404 can be found in the readme.
   Thanks.
Comment 11 邱焜 2009-03-29 05:38:59 UTC
DUCK% sudo ./iow --addr 0xE404 --width 8 --value 0x1C01

 the value written into IO port 0xe404 is 1c01
DUCK% sudo ./ior --addr 0xE404 --width 8               

 the value of IO port 0xe404 is 1

i cant find a option to disable the acpi support of the box. so i boot with "acpi=off". and did as below. Nothing happened.
Comment 12 ykzhao 2009-04-03 08:00:38 UTC
Thanks for the test.
    From the test it seems that the box can't be shutdown by accessing the PM1A control register directly. And it can't be shutdown by using APM.
    As this is a very old box, we don't know whether the ACPI is supported very well. And it is very weird that windows can work well on this box. Maybe some specific registers are used in windows. But we don't know.
    Now I have no idea how to fix this.
    Thanks.
Comment 13 ykzhao 2009-04-10 15:55:45 UTC
Will you please add the boot option of "acpi_sleep=old_ordering" and see whether the box can be shutdown by using hibernate?
   a. make sure that platform mode is selected. ( cat /sys/power/disk)
   b. echo disk > /sys/power/state and see whether the box can be shutdown

   Thanks.
Comment 14 邱焜 2009-04-14 11:14:37 UTC
Now im using the 2.6.29 kernel, if it's necessary, i can use the older.

DUCK% sudo dmesg|grep acpi    
密码:
Kernel command line: root=/dev/sda8 acpi_sleep=old-ordering ro
DUCK% sudo cat /sys/power/disk
[platform] test testproc shutdown reboot

echo disk > /sys/power/state can shutdown, but screen has a '_';, the box's power still not down.

How evil this box is!

And i have seen this:
FADT: X_PM1a_EVT_BLK.bit_width (16) does not match PM1_EVT_LEN (4)
in dmesg.
Comment 15 ykzhao 2009-06-19 02:04:35 UTC
Sorry for the late response.
   Please ignore the message:
    FADT: X_PM1a_EVT_BLK.bit_width (16) does not match PM1_EVT_LEN (4)
in dmesg
   This is already fixed in the latest kernel.
   
   On this box the main issue is that the box can't be shutdown by writing the SLP_TYP to PM1A control register. And it can't be shutdown by using APM, either.
   As this is a very old box, we don't know whether the ACPI is supported very
well. And it is very weird that windows can work well on this box. Maybe some
specific registers are used in windows. But we don't know.
    Now I have no idea how to fix this.

   Thanks.
Comment 16 邱焜 2009-06-19 07:21:01 UTC
Thanks anyway.

But I must tell you that the early kernel works well in my broken chipset(not using and i forgot its model number), but the newly kernel cant shutdown. Maybe this bug not only affect this two chipset. 

This message seems to help nothing. = =
Comment 17 ykzhao 2009-07-06 01:57:11 UTC
As this box can't be shutdown by writing S5 SLP_TYPE to PM1A control register, it will be marked as the duplicated bug of 8549.

thanks.

*** This bug has been marked as a duplicate of bug 8549 ***
Comment 18 camelseller 2011-08-30 17:15:30 UTC
Hello, I have the same problem on an ASUS CUSI-FX motherboard, the pc don't poweroff. Message will now halt on screen and power led turned off but the pc is still on.

maybe it helps:

http://pastebin.com/P97rjB3M
http://pastebin.com/unL7ryd4
http://pastebin.com/i9x5wr6g
http://pastebin.com/njLscLCq
http://pastebin.com/YUg8HzSR
http://pastebin.com/mRAsJ9uw

tried with debian wheezy and ubuntu dapper.
This is the first time I write on pastebin, let me know if I have to do more tests.

Sorry for my bad english.

bye

Note You need to log in before you can comment on or make changes to this bug.