Bug 12669 - 2.6.28.4 regression: mmap fails if mlockall used
2.6.28.4 regression: mmap fails if mlockall used
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-08 12:23 UTC by Rafael J. Wysocki
Modified: 2009-02-08 14:02 UTC (History)
0 users

See Also:
Kernel Version: 2.6.28.4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-08 12:23:31 UTC
Subject    : 2.6.28.4 regression: mmap fails if mlockall used
Submitter  : Sami Farin <safari-kernel@safari.iki.fi>
Date       : 2009-02-08 10:52
References : http://marc.info/?l=linux-kernel&m=123409037423068&w=4
Notify-Also : Hugh Dickins <hugh@veritas.com>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-08 14:02:13 UTC
On Sunday 08 February 2009, Linus Torvalds wrote:
> 
> On Sun, 8 Feb 2009, Rafael J. Wysocki wrote:
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12669
> > Subject		: 2.6.28.4 regression: mmap fails if mlockall used
> > Submitter	: Sami Farin <safari-kernel@safari.iki.fi>
> > Date		: 2009-02-08 10:52 (1 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123409037423068&w=4
> 
> Oh, Hugh just sent a patch, and it's now commit 
> d5b562330ec766292a3ac54ae5e0673610bd5b3d. Sadly this just missed -rc4 by 
> something like 20 minutes..
> 
> 		Linus


Note You need to log in before you can comment on or make changes to this bug.