Bug 12667 - Badness at kernel/time/timekeeping.c:98 in pmud (timekeeping_suspended)
Badness at kernel/time/timekeeping.c:98 in pmud (timekeeping_suspended)
Status: CLOSED WILL_FIX_LATER
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32
All Linux
: P1 normal
Assigned To: platform_ppc-32
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-02-08 12:15 UTC by Rafael J. Wysocki
Modified: 2009-04-26 10:51 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-08 12:15:10 UTC
Subject    : Badness at kernel/time/timekeeping.c:98 in pmud (timekeeping_suspended)
Submitter  : Paul Collins <paul@burly.ondioline.org>
Date       : 2009-01-21 7:15
References : http://marc.info/?l=linux-kernel&m=123252215315106&w=4
Notify-Also : Thomas Gleixner <tglx@linutronix.de>
Notify-Also : Ingo Molnar <mingo@elte.hu>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 1c5745aa380efb6417b5681104b007c8612fb496
Author: Thomas Gleixner <tglx@linutronix.de>
Date:   Mon Dec 22 23:05:28 2008 +0100

    sched_clock: prevent scd->clock from moving backwards, take #2

    Cc: <stable@kernel.org>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 1c5745aa380efb6417b5681104b007c8612fb496
Comment 1 Rafael J. Wysocki 2009-02-14 14:42:04 UTC
On Monday 09 February 2009, Paul Collins wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12667
> > Subject		: Badness at kernel/time/timekeeping.c:98 in pmud (timekeeping_suspended)
> > Submitter	: Paul Collins <paul@burly.ondioline.org>
> > Date		: 2009-01-21 7:15 (19 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1c5745aa380efb6417b5681104b007c8612fb496
> > References	: http://marc.info/?l=linux-kernel&m=123252215315106&w=4
> 
> I've just done ten suspend/resume cycles with 2.6.29-rc4 and this
> message was not logged, so it's either gone away or else become much
> more difficult to reproduce.

Comment 2 Rafael J. Wysocki 2009-02-16 13:16:06 UTC
On Monday 16 February 2009, Paul Collins wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > On Monday 09 February 2009, Paul Collins wrote:
> >> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> >> 
> >> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12667
> >> > Subject		: Badness at kernel/time/timekeeping.c:98 in pmud (timekeeping_suspended)
> >> > Submitter	: Paul Collins <paul@burly.ondioline.org>
> >> > Date		: 2009-01-21 7:15 (19 days old)
> >> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1c5745aa380efb6417b5681104b007c8612fb496
> >> > References	: http://marc.info/?l=linux-kernel&m=123252215315106&w=4
> >> 
> >> I've just done ten suspend/resume cycles with 2.6.29-rc4 and this
> >> message was not logged, so it's either gone away or else become much
> >> more difficult to reproduce.
> >
> > Thanks, I've closed the bug.
> 
> It turns out I didn't test this properly.  The warning is only triggered
> when I close and open the lid, not when I run 'snooze' to suspend and
> hit Return to resume, as I did for my so-called testing of 2.6.29-rc4.
> 
> Whatever is triggering the warning is still present in 2.6.29-rc5.

Comment 3 Rafael J. Wysocki 2009-02-16 13:16:40 UTC
Patch : http://lkml.org/lkml/2009/2/16/78
Comment 4 Rafael J. Wysocki 2009-02-16 13:17:29 UTC
Handled-By : Benjamin Herrenschmidt <benh@kernel.crashing.org>
Comment 5 Rafael J. Wysocki 2009-02-23 16:07:12 UTC
First-Bad-Commit : 1c5745aa380efb6417b5681104b007c8612fb496
Comment 6 Rafael J. Wysocki 2009-04-26 10:50:52 UTC
This problem is not being worked on any more.  Closing.

Note You need to log in before you can comment on or make changes to this bug.