Bug 12661 - commit 64ff3b938ec6782e6585a83d5459b98b0c3f6eb8 breaks rlogin
commit 64ff3b938ec6782e6585a83d5459b98b0c3f6eb8 breaks rlogin
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-08 11:36 UTC by Rafael J. Wysocki
Modified: 2009-02-14 14:35 UTC (History)
0 users

See Also:
Kernel Version: commit 64ff3b938ec6782e6585a83d5459b98b0c3f6eb8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-08 11:36:25 UTC
Subject    : commit 64ff3b938ec6782e6585a83d5459b98b0c3f6eb8 breaks rlogin
Submitter  : Jeff Chua <jeff.chua.linux@gmail.com>
Date       : 2009-02-05 14:41
References : http://marc.info/?l=linux-kernel&m=123384496107361&w=4
Handled-By : Herbert Xu <herbert@gondor.apana.org.au>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 64ff3b938ec6782e6585a83d5459b98b0c3f6eb8
Author: Herbert Xu <herbert@gondor.apana.org.au>
Date:   Thu Dec 25 17:12:58 2008 -0800

    tcp: Always set urgent pointer if it's beyond snd_nxt

    Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
    Signed-off-by: David S. Miller <davem@davemloft.net>

First-Bad-Commit : 64ff3b938ec6782e6585a83d5459b98b0c3f6eb8
Comment 1 Rafael J. Wysocki 2009-02-14 14:34:02 UTC
On Monday 09 February 2009, Herbert Xu wrote:
> On Sun, Feb 08, 2009 at 08:21:46PM +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> 
> The patch in question has already been reverted.  So while we
> still need to track down the underlying problem with rlogin, it's
> no longer a kernel regression.


Note You need to log in before you can comment on or make changes to this bug.