Bug 12652 - rb433 ah hangs when we use ath5k and ping it with large size datat bytes
Summary: rb433 ah hangs when we use ath5k and ping it with large size datat bytes
Status: CLOSED DUPLICATE of bug 12647
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Bob Copeland
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-07 09:24 UTC by satish
Modified: 2009-02-10 04:32 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27.13
Tree: Mainline
Regression: Yes


Attachments

Description satish 2009-02-07 09:24:57 UTC
Latest working kernel version:2.6.27.13
Earliest failing kernel version:2.6.26.5
Distribution:kamikaze (openwrt)
Hardware Environment: rb433 ah board ( AR7161 processor)
Software Environment: 
Problem Description:
This is satish from Indian Institute of Science. I am working on 802.11s implementation.

We are using routerboard 433ah platform which has atheros processor.
The wifi chip we are using is AR5413. We are using ath5k driver downloaded from compat wireless.

Our board reboots at higher clock frequency (> 100 MHZ). The processor hangs approx. five minutes after we bring the wlan0 interface up.
When we ping from the board with higher size data bytes ( Ex: ping -s 128 ), the board hangs after two pings in higher clock frequency. The same problem occurs when we ping our board from some other system. But the above issue does not arise when the clock frequency is 100 MHZ.

So we doubt the above problem is due to the insufficient buffer size. When the board runs at higher clock freq., the buffer gets filled up immediately.

I, therefore, request you to suggest some parameters with which we can play to bring the buffer size up. If you think it is not due to the buffer size, please suggest a solution. The card works fine with madwifi driver. So there is no issue with the hardware.

Steps to reproduce:
connect to ad hoc network 
ping to any station with large size data bytes ex: ping -s 128
Comment 1 Andrew Morton 2009-02-07 10:55:40 UTC
> Latest working kernel version:2.6.27.13
> Earliest failing kernel version:2.6.26.5

I assumed these were reversed, and marked it as a regression.
Comment 2 Bob Copeland 2009-02-09 11:03:21 UTC
Is this a duplicate of 12647?

http://bugzilla.kernel.org/show_bug.cgi?id=12647 - please try the suggestions there.
Comment 3 Bob Copeland 2009-02-10 04:25:21 UTC

*** This bug has been marked as a duplicate of bug 12647 ***

Note You need to log in before you can comment on or make changes to this bug.